summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkari-chan2021-05-12 23:13:31 +0300
committerAkari-chan2021-05-12 23:13:31 +0300
commit1be3cdfb73a7462090bec2f5d8c04997e0376e83 (patch)
tree1fdd67054698443315d6611d7b27185027e405ab
downloadaur-1be3cdfb73a7462090bec2f5d8c04997e0376e83.tar.gz
initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD52
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f90c5cc19fbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = lsidups-git
+ pkgdesc = Find duplicates / similar images from your terminal and export them as list or json
+ pkgver = r96.1c468cd
+ pkgrel = 1
+ url = https://github.com/MahouShoujoMivutilde/lsidups
+ arch = x86_64
+ arch = aarch64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = go
+ optdepends = sxiv: visually compare images (lsidups -i dir | sxiv -i)
+ optdepends = imv: visually compare images (lsidups -i dir | imv)
+ optdepends = python-pillow: to make sorting in groups of duplicates smarter, see examples dir
+ optdepends = fd: for lsvdups script, see examples
+ optdepends = ffmpegthumbnailer: for lsvdups script, see examples
+ provides = lsidups
+ conflicts = lsidups
+ source = lsidups-git::git+https://github.com/MahouShoujoMivutilde/lsidups.git
+ sha256sums = SKIP
+
+pkgname = lsidups-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d08af7e33826
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Akari-chan <`echo YmJlZWRzaTRAYW5vbmFkZHkubWUK | base64 -d`>
+
+pkgname=lsidups-git
+_pkgname=${pkgname%-git}
+pkgver=r96.1c468cd
+pkgrel=1
+
+pkgdesc='Find duplicates / similar images from your terminal and export them as list or json'
+url='https://github.com/MahouShoujoMivutilde/lsidups'
+arch=('x86_64' 'aarch64' 'i686')
+license=('MIT')
+
+makedepends=('git' 'go')
+
+optdepends=('sxiv: visually compare images (lsidups -i dir | sxiv -i)'
+ 'imv: visually compare images (lsidups -i dir | imv)'
+ 'python-pillow: to make sorting in groups of duplicates smarter, see examples dir'
+ 'fd: for lsvdups script, see examples'
+ 'ffmpegthumbnailer: for lsvdups script, see examples')
+
+source=("$pkgname::git+$url.git")
+sha256sums=(SKIP)
+
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf 'r%s.%s\n' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ CGO_ENABLED=0 go build \
+ -trimpath \
+ -mod=readonly \
+ -ldflags "-s -w -X main.GitVersion=${pkgver}" \
+ .
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -m 644 -D LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -m 644 -D README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
+
+ install -m 755 -D -t "$pkgdir/usr/bin" $_pkgname
+
+ # can be used directly, but i expect those to be edited by end-user
+ install -m 755 -D -t "$pkgdir/usr/share/doc/$_pkgname/examples" examples/*
+}