summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2023-12-04 19:47:43 +0100
committerLuca Weiss2023-12-04 19:47:43 +0100
commita0adb51d7586e41806e8010d3f9871fc56a2bc56 (patch)
tree1f94111e78124b20c224c8c9fd4cc8e180c6ec8e
downloadaur-a0adb51d7586e41806e8010d3f9871fc56a2bc56.tar.gz
Initial upload: lsip6 0.1.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6222c7032410
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lsip6
+ pkgdesc = Find link-local IPv6 neighbors on point-to-point links
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://git.sr.ht/~martijnbraam/lsip6
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://git.sr.ht/~martijnbraam/lsip6/archive/0.1.0.tar.gz
+ sha512sums = f10a16653b61d29a046a62b19552ce08fee370dc9870fcccc06a3460efb7490a89986813b0f1fedf711bd13a5b72351e819a9f77aac2558398124b12e5815484
+
+pkgname = lsip6
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d285283f3cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=lsip6
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Find link-local IPv6 neighbors on point-to-point links"
+arch=('any')
+url="https://git.sr.ht/~martijnbraam/lsip6"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://git.sr.ht/~martijnbraam/lsip6/archive/$pkgver.tar.gz")
+sha512sums=('f10a16653b61d29a046a62b19552ce08fee370dc9870fcccc06a3460efb7490a89986813b0f1fedf711bd13a5b72351e819a9f77aac2558398124b12e5815484')
+
+build() {
+ cd "lsip6-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "lsip6-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}