summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBranislav Holý2016-03-14 11:34:09 +0100
committerBranislav Holý2016-03-14 11:34:09 +0100
commite5ff241e84494e4380c1cd5618ed1bf375c1d7b4 (patch)
treef753b2461c6f68427a412a98cdd0f75f36441e42
parentd54094df0bdc3b1ee6033010045e6cfacf81058b (diff)
downloadaur-e5ff241e84494e4380c1cd5618ed1bf375c1d7b4.tar.gz
Changed to a split package.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 36 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3326b10ac8b9..167ac9a834af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by pakanton
pkgbase = lsl-registration
pkgver = 0.1.3
- pkgrel = 1
+ pkgrel = 2
pkgdesc = A library for working with LIDAR data
url = https://github.com/branoholy/lsl
arch = i686
@@ -12,9 +12,8 @@ pkgbase = lsl-registration
arch = aarch64
license = GPL3
makedepends = cmake>=2.8
+ makedepends = lsl-core>=0.1.3
makedepends = boost>=1.54
- depends = lsl-core>=0.1.3
- depends = lsl-registration-lib>=0.1.3
source = https://github.com/branoholy/lsl/archive/v0.1.3/lsl-0.1.3.tar.gz
source = https://github.com/branoholy/lsl/releases/download/v0.1.3/lsl-0.1.3.tar.gz.sig
md5sums = 1bfbf88bcccc81c519dab49c4e57d07c
@@ -27,3 +26,11 @@ pkgbase = lsl-registration
sha512sums = 4e716b35bc71b4f51b43857ccd7dc1e4ec5fbb5af22eb60a1d393a59ef62398c3a5b07db6aaab96b7cf220d0b08efa3e28a5060f78589b81c3345990e0dbf1cc
pkgname = lsl-registration
+ pkgdesc = A library for working with LIDAR data - development headers
+ depends = lsl-core>=0.1.3
+ depends = lsl-registration-lib=0.1.3
+
+pkgname = lsl-registration-lib
+ pkgdesc = A library for working with LIDAR data - runtime library
+ depends = lsl-core-lib>=0.1.3
+ depends = yaml-cpp>=0.5
diff --git a/PKGBUILD b/PKGBUILD
index 01de6940fc46..83315b46424c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Generated by pakanton
# Maintainer: Branislav Holý <branoholy@gmail.com>
-pkgname=lsl-registration
-pkgver=0.1.3
-pkgrel=1
-pkgdesc="A library for working with LIDAR data"
+pkgbase='lsl-registration'
+pkgname=('lsl-registration' 'lsl-registration-lib')
+pkgver='0.1.3'
+pkgrel='2'
+pkgdesc='A library for working with LIDAR data'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/branoholy/lsl"
+url='https://github.com/branoholy/lsl'
license=('GPL3')
-makedepends=('cmake>=2.8' 'boost>=1.54')
-depends=('lsl-core>=0.1.3' 'lsl-registration-lib>=0.1.3')
+makedepends=('cmake>=2.8' 'lsl-core>=0.1.3' 'boost>=1.54')
source=("https://github.com/branoholy/lsl/archive/v$pkgver/lsl-$pkgver.tar.gz"
"https://github.com/branoholy/lsl/releases/download/v$pkgver/lsl-$pkgver.tar.gz.sig")
md5sums=('1bfbf88bcccc81c519dab49c4e57d07c'
@@ -23,12 +23,28 @@ validpgpkeys=('D25809BF3563AA56A12B0F4D545EDD46FBAC61E6')
build() {
cd lsl-$pkgver
- mkdir -p build && cd build
+
+ mkdir -p builds/lsl-registration && cd builds/lsl-registration
cmake -Dinstall-headers:bool=on -Dlibrary:string=registration -DCMAKE_INSTALL_PREFIX=/usr ..
make
+
+ mkdir -p ../lsl-registration-lib && cd ../lsl-registration-lib
+ cmake -Dinstall-library:bool=on -Dlibrary:string=registration -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package_lsl-registration() {
+ pkgdesc='A library for working with LIDAR data - development headers'
+ depends=("lsl-core>=$pkgver" "lsl-registration-lib=$pkgver")
+
+ cd lsl-$pkgver/builds/$pkgname
+ make DESTDIR="$pkgdir/" install
}
-package() {
- cd lsl-$pkgver/build
+package_lsl-registration-lib() {
+ pkgdesc='A library for working with LIDAR data - runtime library'
+ depends=("lsl-core-lib>=$pkgver" 'yaml-cpp>=0.5')
+
+ cd lsl-$pkgver/builds/$pkgname
make DESTDIR="$pkgdir/" install
}