summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-10-23 21:38:04 +0200
committeraksr2015-10-23 21:38:04 +0200
commitbb5c1c71498bed1fa9a6aed594eaae0c11f8d2b5 (patch)
tree87af7dfdbd30d0cc02fc6a72e386deecb5c3ffbb
downloadaur-bb5c1c71498bed1fa9a6aed594eaae0c11f8d2b5.tar.gz
Start.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b5d06e186fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lsp-git
+ pkgdesc = Lists files, like ls command, but more human-friendly.
+ pkgver = 0.2.0.r76.g8e31ae4
+ pkgrel = 1
+ url = https://github.com/dborzov/lsp
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ conflicts = lsp
+
+pkgname = lsp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f68fbb65a7eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=lsp-git
+pkgver=0.2.0.r76.g8e31ae4
+pkgrel=1
+epoch=
+pkgdesc="Lists files, like ls command, but more human-friendly."
+arch=('i686' 'x86_64')
+url="https://github.com/dborzov/lsp"
+license=('MIT')
+groups=()
+depends=('')
+makedepends=('git' 'go')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('lsp')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+noextract=()
+_gourl=github.com/dborzov/lsp
+
+pkgver() {
+ cd "$srcdir/src/${_gourl}"
+ git describe --tags | sed -E 's/^v//g;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ GOPATH="$srcdir" go get -fix -v -x ${_gourl}
+}
+
+check() {
+ GOPATH="$srcdir" go test -v -x ${_gourl}
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 bin/lsp "$pkgdir/usr/bin/lsp"
+ install -Dm644 src/${_gourl}/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+