summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hoeflich2021-03-22 11:07:34 -0500
committerJoshua Hoeflich2021-03-22 11:07:34 -0500
commit060a2d55102bfaf9f776d31f801e29f10b90a9c6 (patch)
tree465ee7b79f630658f3bb0f0e41b816d2e25abb1b
downloadaur-060a2d55102bfaf9f776d31f801e29f10b90a9c6.tar.gz
Initial kermit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c80d34aba9bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lsr-git
+ pkgdesc = List files recursively.
+ pkgver = main
+ pkgrel = 1
+ url = https://github.com/joshuahoeflich/lsr
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = https://github.com/joshuahoeflich/lsr-git/archive/main.tar.gz
+ md5sums = b7a9e4a0e5ae141868b195e5fc916381
+
+pkgname = lsr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d6f9f7cf64d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+#!/usr/bin/env bash
+# Maintainer: Your Name <josh@joshuahoeflich.com>
+pkgname=lsr-git
+pkgver=main
+pkgrel=1
+pkgdesc="List files recursively."
+arch=('x86_64')
+url="https://github.com/joshuahoeflich/lsr"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('cargo')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/joshuahoeflich/${pkgname}/archive/main.tar.gz")
+noextract=()
+md5sums=('b7a9e4a0e5ae141868b195e5fc916381')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir"/usr/bin
+ cp target/release/lsr "$pkgdir"/usr/bin
+}