summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze2018-11-29 18:02:15 +0100
committerNoel Kuntze2018-11-29 18:02:15 +0100
commitaddf6a3b3bc3824ecb80187424702a51e2abd753 (patch)
tree5a2f659f02107b47ca6913d37d5ba03b3e011b6d
parentcfd38e6f579a970f62f7b764382abff4d7c53fa4 (diff)
downloadaur-addf6a3b3bc3824ecb80187424702a51e2abd753.tar.gz
Change lua52 to lua, escape some variables
-rw-r--r--.SRCINFO10
-rw-r--r--FindLua.cmake.patch12
-rw-r--r--PKGBUILD29
3 files changed, 36 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5a01e6eb96c..9156b9a44995 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
# Generated by mksrcinfo v8
-# Wed Apr 11 17:20:50 UTC 2018
+# Thu Nov 29 17:01:16 UTC 2018
pkgbase = lsyncd
pkgdesc = Live Syncing (Mirror) Daemon
pkgver = 2.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/axkibe/lsyncd
arch = i686
arch = x86_64
license = GPL2
makedepends = asciidoc
- makedepends = lua52
+ makedepends = lua
makedepends = cmake
- depends = lua52
+ depends = lua
depends = rsync
source = https://github.com/axkibe/lsyncd/archive/release-2.2.3.tar.gz
source = lsyncd.service
+ source = FindLua.cmake.patch
sha256sums = 7bcd0f4ae126040bb078c482ff856c87e61c22472c23fa3071798dcb1dc388dd
sha256sums = 538072a4505abbdf8c4d16c9200810d4a2253f892a71fc16b5cd7f35ebe1ae57
+ sha256sums = 98396b0e6c1cf55f53b3be84a1ca910aa485cd975d2a489413f665b4d37dad10
pkgname = lsyncd
diff --git a/FindLua.cmake.patch b/FindLua.cmake.patch
new file mode 100644
index 000000000000..e6db02d7ee2b
--- /dev/null
+++ b/FindLua.cmake.patch
@@ -0,0 +1,12 @@
+diff lsyncd-release-2.1.5.orig/cmake/FindLua.cmake lsyncd-release-2.1.5/cmake/FindLua.cmake
+--- a/cmake/FindLua.cmake
++++ b/cmake/FindLua.cmake
+@@ -36,7 +36,7 @@ SET(_POSSIBLE_LUA_INCLUDE include include/lua)
+ #SET(_POSSIBLE_LUA_LIBRARY lua)
+
+ # Determine possible naming suffixes (there is no standard for this)
+-SET(_POSSIBLE_SUFFIXES "52" "5.2" "-5.2" "53" "5.3" "-5.3" "")
++SET(_POSSIBLE_SUFFIXES "53" "5.3" "-5.3" "52" "5.2" "-5.2" "")
+
+ # Set up possible search names and locations
+ FOREACH(_SUFFIX ${_POSSIBLE_SUFFIXES}) \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 8113c000eea4..bc8dcde92b8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,28 @@
# Submitter: nullie
pkgname=lsyncd
pkgver=2.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="Live Syncing (Mirror) Daemon"
arch=('i686' 'x86_64')
url="https://github.com/axkibe/lsyncd"
license=('GPL2')
-depends=('lua52' 'rsync')
-makedepends=('asciidoc' 'lua52' 'cmake')
+depends=('lua' 'rsync')
+makedepends=('asciidoc' 'lua' 'cmake')
source=("https://github.com/axkibe/lsyncd/archive/release-$pkgver.tar.gz"
- "lsyncd.service")
+ "lsyncd.service"
+ "FindLua.cmake.patch")
sha256sums=('7bcd0f4ae126040bb078c482ff856c87e61c22472c23fa3071798dcb1dc388dd'
- '538072a4505abbdf8c4d16c9200810d4a2253f892a71fc16b5cd7f35ebe1ae57')
+ '538072a4505abbdf8c4d16c9200810d4a2253f892a71fc16b5cd7f35ebe1ae57'
+ '98396b0e6c1cf55f53b3be84a1ca910aa485cd975d2a489413f665b4d37dad10')
+
+prepare() {
+ cd "${pkgname}-release-${pkgver}"
+ patch -Np1 -i "${srcdir}/FindLua.cmake.patch"
+}
build() {
- cd $srcdir/$pkgname-release-$pkgver
+ cd ${srcdir}/${pkgname}-release-${pkgver}
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
@@ -24,10 +31,10 @@ build() {
}
package() {
- cd $srcdir/$pkgname-release-$pkgver/build
- make DESTDIR=$pkgdir install
+ cd "${srcdir}/${pkgname}-release-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
# fix the path of the man page. Urgh.
- install -D ${pkgdir}/usr/man/lsyncd.1 ${pkgdir}/usr/share/man/man1/lsyncd.1
- rm -rf ${pkgdir}/usr/man
- install -m 644 -D ${srcdir}/lsyncd.service ${pkgdir}/usr/lib/systemd/system/lsyncd.service
+ install -D "${pkgdir}/usr/man/lsyncd.1" "${pkgdir}/usr/share/man/man1/lsyncd.1"
+ rm -rf "${pkgdir}/usr/man"
+ install -m 644 -D "${srcdir}/lsyncd.service" "${pkgdir}/usr/lib/systemd/system/lsyncd.service"
}