summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzpyg2022-01-23 20:30:58 +0800
committerzpyg2022-01-23 20:30:58 +0800
commit3b5fbb68e453028b46df4240729d31e061a3836f (patch)
tree6bf91dc56c897b9e72633fb1b596553ad8922283
downloadaur-3b5fbb68e453028b46df4240729d31e061a3836f.tar.gz
first
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c498913e5a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ltex-ls-bin
+ pkgdesc = LTeX Language Server: LSP language server for LanguageTool magheavy_check_mark with support for LaTeX mortar_board, Markdown memo, and others
+ pkgver = 15.2.0
+ pkgrel = 1
+ arch = x86_64
+ license = MPL2
+ provides = ltex-ls
+ source = https://github.com/valentjn/ltex-ls/releases/download/15.2.0/ltex-ls-15.2.0-linux-x64.tar.gz
+ md5sums = 6234713566e863420c728e32273ed88c
+
+pkgname = ltex-ls-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f05ead8100c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: pu <pu.mb@qq.com>
+pkgname=ltex-ls-bin
+_pkgname=ltex-ls
+pkgver=15.2.0
+pkgrel=1
+pkgdesc="LTeX Language Server: LSP language server for LanguageTool magheavy_check_mark with support for LaTeX mortar_board, Markdown memo, and others"
+arch=('x86_64')
+usl="https://github.com/valentjn/ltex-ls"
+license=('MPL2')
+provides=('ltex-ls')
+source=("https://github.com/valentjn/ltex-ls/releases/download/15.2.0/ltex-ls-15.2.0-linux-x64.tar.gz")
+md5sums=('6234713566e863420c728e32273ed88c')
+
+package() {
+ install -d "${pkgdir}/opt/${_pkgname}"
+ install -d "${pkgdir}/usr/bin"
+
+ cp -r "${srcdir}/${_pkgname}-${pkgver}/"* "${pkgdir}/opt/${_pkgname}/"
+
+ ln -sf /opt/${_pkgname}/bin/ltex-ls "${pkgdir}"/usr/bin/ltex-ls
+ ln -sf /opt/${_pkgname}/bin/ltex-cli "${pkgdir}"/usr/bin/ltex-cli
+}