summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Chasteen2019-02-19 17:59:52 -0500
committerJonathan Chasteen2019-02-19 17:59:52 -0500
commiteed8262a2dd2d9e2678ef2af5d9edbf889943db3 (patch)
treef90da3387cbf3156a50c38befb9f099120b8db6b
parent155182538a4fac9eb8f6020ec4a85a7c6e3a3ec5 (diff)
downloadaur-eed8262a2dd2d9e2678ef2af5d9edbf889943db3.tar.gz
Update to 2.2.2-2 and remove a patch rendered uncessary by the update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--file_handle_redefinition.patch16
3 files changed, 9 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9319cea59be4..21420b4408b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Feb 22 19:21:54 UTC 2016
pkgbase = ltfs
pkgdesc = Linear Tape File System
- pkgver = 2.1.2
- pkgrel = 1
+ pkgver = 2.2.2
+ pkgrel = 2
url = http://www.quantum.com/products/tapedrives/ltoultrium/lto-5/ltfs/index.aspx
arch = x86_64
arch = i686
@@ -17,11 +15,9 @@ pkgbase = ltfs
depends = icu
depends = libxml2
backup = etc/ltfs.conf.local
- source = http://downloads.quantum.com/open_source/LTFS/2.1.2/5-00732-07.zip
- source = file_handle_redefinition.patch
+ source = http://downloads.quantum.com/open_source/LTFS/2.2.2-2/5-00732-09.zip
source = LICENSE
- sha512sums = 7cab930bbfd38fd2c608232be063aaa00570011cb8f5cbe62293336c175b7f0d4507135bd452917ac1fe3da0f7a138f44765e059a7cd5a37e90c29ecae8b308a
- sha512sums = 81b2462a18c8a21faebc00411293a77958642cded8a29d4a531e2c7590ac3b4107915d6a480f064302b41e2cef819779395e3c357963b8c066c8700b7db3b816
+ sha512sums = c7b430e8f4b05ea0d29fb344d1e8ebf0bb7d85511233e80d6f2d2a585579c05d632ada5edff23da3f6b451ad5a75f4ae49c81ecd78c0349832cdd49ba8943cf4
sha512sums = 865c4a581d32d94537ba8d19f2494ba9da54328cd94cf0cffac25b8f446cdeb062172d7598c45ac85477a239b5e5a9b7342a9a4711c54efa7f47b79d89c9d893
pkgname = ltfs
diff --git a/PKGBUILD b/PKGBUILD
index 2dc2e2208da1..1a0808670fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Janne Heß <jannehess@gmail.com>
pkgname=ltfs
-pkgver=2.1.2
-_pkgver2=5-00732-07
-pkgrel=1
+pkgver=2.2.2
+_pkgver2=5-00732-09
+pkgrel=2
pkgdesc='Linear Tape File System'
arch=('x86_64' 'i686')
url='http://www.quantum.com/products/tapedrives/ltoultrium/lto-5/ltfs/index.aspx'
@@ -11,16 +11,13 @@ license=('custom:ltfs')
depends=('fuse' 'icu' 'libxml2')
makedepends=('patch' 'gcc' 'pkg-config' 'make' 'fakeroot')
backup=('etc/ltfs.conf.local')
-source=("http://downloads.quantum.com/open_source/LTFS/${pkgver}/${_pkgver2}.zip"
- 'file_handle_redefinition.patch'
+source=("http://downloads.quantum.com/open_source/LTFS/${pkgver}-${pkgrel}/${_pkgver2}.zip"
'LICENSE')
-sha512sums=('7cab930bbfd38fd2c608232be063aaa00570011cb8f5cbe62293336c175b7f0d4507135bd452917ac1fe3da0f7a138f44765e059a7cd5a37e90c29ecae8b308a'
- '81b2462a18c8a21faebc00411293a77958642cded8a29d4a531e2c7590ac3b4107915d6a480f064302b41e2cef819779395e3c357963b8c066c8700b7db3b816'
+sha512sums=('c7b430e8f4b05ea0d29fb344d1e8ebf0bb7d85511233e80d6f2d2a585579c05d632ada5edff23da3f6b451ad5a75f4ae49c81ecd78c0349832cdd49ba8943cf4'
'865c4a581d32d94537ba8d19f2494ba9da54328cd94cf0cffac25b8f446cdeb062172d7598c45ac85477a239b5e5a9b7342a9a4711c54efa7f47b79d89c9d893')
prepare() {
tar xf `find "${srcdir}" -name '*.tar.gz'`
- patch -p0 -i "${srcdir}/file_handle_redefinition.patch"
}
build() {
diff --git a/file_handle_redefinition.patch b/file_handle_redefinition.patch
deleted file mode 100644
index b0bbf052e3c4..000000000000
--- a/file_handle_redefinition.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- qtmltfs/src/ltfs_fuse.h.orig 2016-02-21 22:17:14.983402396 +0100
-+++ qtmltfs/src/ltfs_fuse.h 2016-02-21 22:17:32.472807246 +0100
-@@ -152,11 +152,12 @@
- * There is one file_handle structure for each file handle (note that
- * a file may have many open handles).
- */
--struct file_handle {
-+struct file_handle_tmp {
- struct file_info *file_info; /**< open_file data associated with this file handle */
- bool dirty; /**< True if this handle has been written but not synced */
- pthread_mutex_t lock;
- };
-+#define file_handle file_handle_tmp
-
- /**
- * Holds information about open files.