summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Henrik Bruhn2021-01-16 12:50:41 +0100
committerJan-Henrik Bruhn2021-01-16 12:50:41 +0100
commit31aa3cda712d6a018455e63f705c14b6d1fd32c9 (patch)
treeaf2218284010a4080a6d7a63a28444f38822baa1
parent712c5d3bbe3c92db09920f17cf42db65fabb42d2 (diff)
downloadaur-31aa3cda712d6a018455e63f705c14b6d1fd32c9.tar.gz
explicitly set winearch in shell script
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--ltspice-help.sh2
-rw-r--r--ltspice.sh2
4 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03ffa9e53f40..93dcce6f991b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ltspice
pkgdesc = SPICE simulator, schematic capture and waveform viewer. Installation based on Field Update Utility.
- pkgver = 17.20201213.13
+ pkgver = 17.20210112.3
pkgrel = 1
url = http://www.linear.com/designtools/software/
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = ltspice
depends = wine
source = ltspice.sh
source = ltspice-help.sh
- sha256sums = 7f26a5549aa0cdef3d4d9c7885bfe60691cb86f851efaee20e94718c5e7c6c32
- sha256sums = 04fb3968b8572d02a69ee61590c038a9560809160b4c6260ded5f802e9ef859a
+ sha256sums = 3a9cead8237122e068b6475430f0ca5cfa9de66159dfb4b668a28c91b5e2ac60
+ sha256sums = fbdf8d774de0ac74b9298c99aa6e2a96b2a9a36d094fcbed885ab2c07a2bc1ca
pkgname = ltspice
diff --git a/PKGBUILD b/PKGBUILD
index 0e4721084119..5bdcff67fb25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _ltspice_ver_roman="XVII"
_ltspice_ver="17"
pkgname=ltspice
-pkgver=17.20201213.13
+pkgver=17.20210112.3
pkgrel=1
pkgdesc="SPICE simulator, schematic capture and waveform viewer. Installation based on Field Update Utility."
arch=('x86_64')
@@ -18,8 +18,8 @@ _update_url="https://ltspice.analog.com/fieldsync$_ltspice_ver_roman"
source=("$pkgname.sh"
"$pkgname-help.sh")
-sha256sums=('7f26a5549aa0cdef3d4d9c7885bfe60691cb86f851efaee20e94718c5e7c6c32'
- '04fb3968b8572d02a69ee61590c038a9560809160b4c6260ded5f802e9ef859a')
+sha256sums=('3a9cead8237122e068b6475430f0ca5cfa9de66159dfb4b668a28c91b5e2ac60'
+ 'fbdf8d774de0ac74b9298c99aa6e2a96b2a9a36d094fcbed885ab2c07a2bc1ca')
_curl_opts="--silent --connect-timeout 60 --retry 3 --retry-delay 1"
_download_file() {
diff --git a/ltspice-help.sh b/ltspice-help.sh
index 09e52b276734..0cbb4865471c 100644
--- a/ltspice-help.sh
+++ b/ltspice-help.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-export WINEPREFIX=$HOME/.ltspice/env
+export WINEPREFIX=$HOME/.ltspice/env WINEARCH=wine64
wine hh /usr/share/doc/ltspice/ltspice.chm "$@"
diff --git a/ltspice.sh b/ltspice.sh
index d93cf7deb6e2..8ee16f3e67c8 100644
--- a/ltspice.sh
+++ b/ltspice.sh
@@ -7,5 +7,5 @@ if [ ! -d $CONFIG_DIR ]; then
mkdir -p $CONFIG_DIR
touch $CONFIG_DIR/LTspiceXVII.ini
fi
-export WINEPREFIX=$HOME/.ltspice/env
+export WINEPREFIX=$HOME/.ltspice/env WINEARCH=win64
wine /opt/ltspice/XVIIx64 -ini $CONFIG_DIR/LTspiceXVII.ini "$@"