summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Henrik Bruhn2021-04-07 20:48:03 +0200
committerJan-Henrik Bruhn2021-04-07 20:48:03 +0200
commit53ce51156234d742753c0a08c9d0d4eb4432571d (patch)
treecc2439e6a12acd75e1b57635cb6c8a3423b6573e
parent31aa3cda712d6a018455e63f705c14b6d1fd32c9 (diff)
downloadaur-53ce51156234d742753c0a08c9d0d4eb4432571d.tar.gz
Update with wine workaround
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--ltspice-help.sh2
-rw-r--r--ltspice.sh2
4 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93dcce6f991b..b43a32cdfbf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ltspice
pkgdesc = SPICE simulator, schematic capture and waveform viewer. Installation based on Field Update Utility.
- pkgver = 17.20210112.3
+ pkgver = 17.20210406.3
pkgrel = 1
url = http://www.linear.com/designtools/software/
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = ltspice
depends = wine
source = ltspice.sh
source = ltspice-help.sh
- sha256sums = 3a9cead8237122e068b6475430f0ca5cfa9de66159dfb4b668a28c91b5e2ac60
- sha256sums = fbdf8d774de0ac74b9298c99aa6e2a96b2a9a36d094fcbed885ab2c07a2bc1ca
+ sha256sums = 8e58856d3920504b16d70d6cdc11abd722a9fdcdc1e9041dd3bef6501063c2d3
+ sha256sums = ff14cff95172bbf685bc39801910edd70ee9499dee450270529c043946cc591c
pkgname = ltspice
diff --git a/PKGBUILD b/PKGBUILD
index 5bdcff67fb25..742b7a823133 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _ltspice_ver_roman="XVII"
_ltspice_ver="17"
pkgname=ltspice
-pkgver=17.20210112.3
+pkgver=17.20210406.3
pkgrel=1
pkgdesc="SPICE simulator, schematic capture and waveform viewer. Installation based on Field Update Utility."
arch=('x86_64')
@@ -18,8 +18,8 @@ _update_url="https://ltspice.analog.com/fieldsync$_ltspice_ver_roman"
source=("$pkgname.sh"
"$pkgname-help.sh")
-sha256sums=('3a9cead8237122e068b6475430f0ca5cfa9de66159dfb4b668a28c91b5e2ac60'
- 'fbdf8d774de0ac74b9298c99aa6e2a96b2a9a36d094fcbed885ab2c07a2bc1ca')
+sha256sums=('8e58856d3920504b16d70d6cdc11abd722a9fdcdc1e9041dd3bef6501063c2d3'
+ 'ff14cff95172bbf685bc39801910edd70ee9499dee450270529c043946cc591c')
_curl_opts="--silent --connect-timeout 60 --retry 3 --retry-delay 1"
_download_file() {
diff --git a/ltspice-help.sh b/ltspice-help.sh
index 0cbb4865471c..7552a3d230d2 100644
--- a/ltspice-help.sh
+++ b/ltspice-help.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-export WINEPREFIX=$HOME/.ltspice/env WINEARCH=wine64
+export WINEPREFIX=$HOME/.ltspice/env WINEARCH=win64
wine hh /usr/share/doc/ltspice/ltspice.chm "$@"
diff --git a/ltspice.sh b/ltspice.sh
index 8ee16f3e67c8..09cf08d7fc95 100644
--- a/ltspice.sh
+++ b/ltspice.sh
@@ -8,4 +8,4 @@ if [ ! -d $CONFIG_DIR ]; then
touch $CONFIG_DIR/LTspiceXVII.ini
fi
export WINEPREFIX=$HOME/.ltspice/env WINEARCH=win64
-wine /opt/ltspice/XVIIx64 -ini $CONFIG_DIR/LTspiceXVII.ini "$@"
+wine /usr/lib/wine/start.exe /unix /opt/ltspice/XVIIx64 -ini $CONFIG_DIR/LTspiceXVII.ini "$@"