summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Henrik Bruhn2020-11-21 13:21:01 +0100
committerJan-Henrik Bruhn2020-11-21 13:21:01 +0100
commit991223055a46be7e846e4403af0fd22c41313ef9 (patch)
tree4f1c177e2e055c1264f1bc075aa299b1ef0ff4f2
parentbc19cc14744d6fd929365a314448aea1e33004ae (diff)
downloadaur-991223055a46be7e846e4403af0fd22c41313ef9.tar.gz
Update version, fix build error
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2ac2f49f875..95105ff433c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ltspice
pkgdesc = SPICE simulator, schematic capture and waveform viewer. Installation based on Field Update Utility.
- pkgver = 17.20201117.1
- pkgrel = 2
+ pkgver = 17.20201120.2
+ pkgrel = 1
url = http://www.linear.com/designtools/software/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 518ef5e05aca..a03ac934cb3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ _ltspice_ver_roman="XVII"
_ltspice_ver="17"
pkgname=ltspice
-pkgver=17.20201117.1
-pkgrel=2
+pkgver=17.20201120.2
+pkgrel=1
pkgdesc="SPICE simulator, schematic capture and waveform viewer. Installation based on Field Update Utility."
arch=('x86_64')
url="http://www.linear.com/designtools/software/"
@@ -38,11 +38,13 @@ _download_file() {
if [ "$_download" = true ]; then
mkdir -p "${pkgname}/$(dirname $file)"
+ output="$pkgname/$file"
+ if [ -f "$output" ]; then
+ rm -f $output
+ fi
# first try compressed path and decompress
url="${_update_url}/${file}.gz"
- output="$pkgname/$file"
compressed="${pkgname}/${file}.gz"
-
curl -f $_curl_opts $url > $compressed && curlcode=$? || curlcode=$?
if [ -s "$compressed" ] && [ $curlcode -eq 0 ]; then
# echo "compressed: $output"
@@ -97,7 +99,7 @@ open_sem $N
build() {
release_logs="$_update_url/release.log.gz"
- curl "$release_logs" | gunzip > ./release.log
+ curl $_curl_opts "$release_logs" | gunzip > ./release.log
echo "Checking cache and downloading using $N threads."
for entry in $(cat release.log | sed '/^#/d' | awk '{print $6"/"$8}')