summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Stabel2019-07-05 22:35:22 +0200
committerMax Stabel2019-07-05 22:35:22 +0200
commitf2fe56641b975a4ed611c8b8e4e25db1674165fb (patch)
treeb6ffd6719960fd4cc553373f6f4a684a82204a36
parent6b9370a65023f20411c2d657314a19ffb480733f (diff)
downloadaur-f2fe56641b975a4ed611c8b8e4e25db1674165fb.tar.gz
Update PKGBUILD & using seperate wineprefix now
-rw-r--r--PKGBUILD12
-rw-r--r--ltspice-help.sh2
-rw-r--r--ltspice.sh2
3 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e7ba14e43a7..4dc9af31a3fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Max Stabel <max dot stabel03 at gmail dot com>
pkgname=ltspice
-pkgver=17
+pkgver=17_20190621
pkgrel=1
pkgdesc="SPICE simulator, schematic capture and waveform viewer of electronic circuits."
arch=('x86_64')
@@ -9,12 +9,12 @@ url="http://www.linear.com/designtools/software/"
license=('custom')
depends=('wine')
makedepends=('git')
-source=("$pkgname::git+https://github.com/M4a1x/$pkgname#branch=$pkgver"
+source=("$pkgname::git+https://github.com/M4a1x/$pkgname#branch=${pkgver//_/-}"
"$pkgname.sh"
"$pkgname-help.sh")
sha256sums=('SKIP'
- '993042982a827ac8bd28490f3433715383eaf78e75f2af883a53b1fa7277fed6'
- 'fa6d9e6a8c64501d1eed2087b37e3a4245ed051c8a5fbc131f6f7ab9bebb8eea')
+ '2652e6154d50a282eb64ad3e50fbb80f4ad62643acead5c39f72c7713daf23cd'
+ 'cc757c939ac9a74af019eeb3fe99a0e44f8624a65d86ed5cd1fed33ae5bc7aab')
package()
{
@@ -25,10 +25,10 @@ package()
rm License.txt
# Install docs to /usr/share/doc/
- install -Dm644 LTspiceHelp.chm "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+ install -Dm644 LTspiceHelp.chm "${pkgdir}/usr/share/doc/${pkgname}/ltspice.chm"
# Install binary files to /usr/share
- mkdir -p "$pkgdir/usr/share/$pkgname"
+ install -m755 -d "$pkgdir/usr/share/$pkgname"
cp -r * "$pkgdir/usr/share/$pkgname"
chmod 755 -R "$pkgdir/usr/share/$pkgname"
diff --git a/ltspice-help.sh b/ltspice-help.sh
index 6806a14e7a41..53e8a274a084 100644
--- a/ltspice-help.sh
+++ b/ltspice-help.sh
@@ -1,3 +1,3 @@
#!/bin/bash
-unset WINEPREFIX
+export WINEPREFIX=$HOME/.ltspice/env
wine /usr/share/doc/ltspice/LTspiceHelp.chm "$@"
diff --git a/ltspice.sh b/ltspice.sh
index f37e408da8fd..c3beb644c9e4 100644
--- a/ltspice.sh
+++ b/ltspice.sh
@@ -1,7 +1,7 @@
#!/bin/bash
-unset WINEPREFIX
if [ ! -d "$HOME"/.ltspice ] ; then
mkdir -p "$HOME"/.ltspice
touch "$HOME"/.ltspice/LTspiceXVII.ini
fi
+export WINEPREFIX=$HOME/.ltspice/env
wine /usr/share/ltspice/XVIIx64 -ini "$HOME"/.ltspice/LTspiceXVII.ini "$@"