summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2015-08-27 09:36:28 +0300
committerChristoph Gysin2015-08-27 09:36:28 +0300
commit1b7e6a9a4352dc149818296fc316da47a9539a07 (patch)
tree999970de9d17e62a711218a66ff5f30c753ab37f
downloadaur-1b7e6a9a4352dc149818296fc316da47a9539a07.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7e84d4a5a8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lttngtop
+ pkgdesc = A top-like, ncurses-based utility to analyze trace information produced by LTTng
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://lttng.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glib2>=2.22.0
+ depends = ncurses
+ depends = popt>=1.13
+ depends = babeltrace
+ source = http://lttng.org/files/lttngtop/lttngtop-0.3.tar.bz2
+ sha1sums = d94a9877267350c5ab5eb2195a3061e04771e6bb
+
+pkgname = lttngtop
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3317ac6609e8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+/*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8a8cfa269e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christian Babeux <christian.babeux@0x80.ca>
+
+pkgname=lttngtop
+pkgver=0.3
+pkgrel=1
+pkgdesc="A top-like, ncurses-based utility to analyze trace information produced by LTTng"
+arch=('i686' 'x86_64')
+url="http://lttng.org/"
+license=('GPL2')
+depends=('glib2>=2.22.0' 'ncurses' 'popt>=1.13' 'babeltrace')
+source=(http://lttng.org/files/$pkgname/$pkgname-$pkgver.tar.bz2)
+sha1sums=('d94a9877267350c5ab5eb2195a3061e04771e6bb')
+
+build()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}