summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2015-08-27 09:36:28 +0300
committerChristoph Gysin2015-08-27 09:36:28 +0300
commitc69a8602e4c724b001b893a9de377f8891b38872 (patch)
treee4c2a577711c34a2985866b3550eb906d625ec63
downloadaur-c69a8602e4c724b001b893a9de377f8891b38872.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db456ebd069f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lttngtop-git
+ pkgdesc = A top-like, ncurses-based utility to analyze trace information produced by LTTng
+ pkgver = 0.3.2.gd0377b6
+ pkgrel = 1
+ url = http://lttng.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glib2>=2.22.0
+ depends = ncurses
+ depends = popt>=1.13
+ depends = babeltrace
+ provides = lttngtop
+ conflicts = lttngtop
+ source = git://git.lttng.org/lttngtop.git
+ sha1sums = SKIP
+
+pkgname = lttngtop-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5b784bdd9392
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar.*
+/lttngtop/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..700ae4ac2131
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Christian Babeux <christian.babeux@0x80.ca>
+
+pkgname=lttngtop-git
+_gitname="lttngtop"
+pkgver=0.3.2.gd0377b6
+pkgrel=1
+pkgdesc="A top-like, ncurses-based utility to analyze trace information produced by LTTng"
+arch=('i686' 'x86_64')
+url="http://lttng.org/"
+license=('GPL2')
+makedepends=('git')
+provides=('lttngtop')
+conflicts=('lttngtop')
+depends=('glib2>=2.22.0' 'ncurses' 'popt>=1.13' 'babeltrace')
+source=('git://git.lttng.org/lttngtop.git')
+sha1sums=('SKIP')
+
+pkgver()
+{
+ cd ${_gitname}
+ git describe --always | sed 's/-/./g;s/^v//'
+}
+
+build()
+{
+ cd ${_gitname}
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package()
+{
+ cd ${_gitname}
+ make install DESTDIR=${pkgdir}
+}