summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:24:16 +0200
committerKevin Brubeck Unhammer2015-07-14 10:24:16 +0200
commitbae3b0e36e1e7e2cb0604499ba8d27bf541b517f (patch)
tree41d20c8ee6229a1da9b9d1033f6f9677fd3601bf
downloadaur-bae3b0e36e1e7e2cb0604499ba8d27bf541b517f.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
3 files changed, 60 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ada97b2e3a20
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = lttoolbox
+ pkgdesc = Handles lexical processing, morphological analysis and generation of words in natural languages using fast finite state transducers.
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = http://wiki.apertium.org/wiki/Lttoolbox
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ depends = libxml2
+ depends = gcc-libs
+ source = http://downloads.sourceforge.net/sourceforge/apertium/lttoolbox-3.3.0.tar.gz
+ options = !libtool
+
+pkgname = lttoolbox
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6781bc7994a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lttoolbox
+ pkgdesc = Handles lexical processing, morphological analysis and generation of words in natural languages using fast finite state transducers.
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = http://wiki.apertium.org/wiki/Lttoolbox
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ depends = libxml2
+ depends = gcc-libs
+ options = !libtool
+ source = http://downloads.sourceforge.net/sourceforge/apertium/lttoolbox-3.3.0.tar.gz
+ md5sums = 001144ffacd544695f5343691cec1824
+ sha256sums = b12cb16f286e87f15eea0e3e988c70e89183eaa6e46a517aff2a4260e52ed773
+
+pkgname = lttoolbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b2894ae9f2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@fsfe.org>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@fsfe.org>
+pkgname=lttoolbox
+pkgver=3.3.0
+pkgrel=1
+pkgdesc="Handles lexical processing, morphological analysis and generation of words in natural languages using fast finite state transducers."
+url="http://wiki.apertium.org/wiki/Lttoolbox"
+license=('GPL')
+makedepends=('pkgconfig')
+depends=('libxml2' 'gcc-libs')
+options=('!libtool')
+arch=('i686' 'x86_64')
+source=(http://downloads.sourceforge.net/sourceforge/apertium/lttoolbox-${pkgver}.tar.gz)
+md5sums=('001144ffacd544695f5343691cec1824')
+sha256sums=('b12cb16f286e87f15eea0e3e988c70e89183eaa6e46a517aff2a4260e52ed773')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}