summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:24:20 +0200
committerKevin Brubeck Unhammer2015-07-14 10:24:20 +0200
commit7f62f06703ca53346fd49a00e869cd54e2bb2725 (patch)
tree461eb0398b3d7c295f87a3914f7a740ef1a7effa
downloadaur-7f62f06703ca53346fd49a00e869cd54e2bb2725.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--Makefile.patch18
-rw-r--r--PKGBUILD29
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2215e3ae0405
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lttoolbox-java
+ pkgdesc = Java port of lttoolbox. Handles lexical processing, morphological analysis and generation of words in natural languages using fast finite state transducers.
+ pkgver = 3.2.0
+ pkgrel = 1
+ url = http://wiki.apertium.org/wiki/Lttoolbox-java
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = apache-ant
+ depends = java-runtime
+ depends = sh
+ options = !libtool
+ source = http://downloads.sourceforge.net/sourceforge/apertium/lttoolbox-java-3.2.0.tar.gz
+ source = Makefile.patch
+ md5sums = 6e029b981a721c6ad515d879e4a6478a
+ md5sums = 2304c7390728fea1b8d0ba2cce2bd780
+
+pkgname = lttoolbox-java
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..2be328d0593d
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,18 @@
+--- ../lttoolbox-java-3.2.0/Makefile 2010-01-26 14:46:14.000000000 +0100
++++ lttoolbox-java-3.2.0/Makefile 2010-09-19 21:01:14.000000000 +0200
+@@ -11,8 +11,13 @@
+ echo "/usr/local" > prefix; \
+ fi
+ @echo installing into `cat prefix`;
+- cp dist/lttoolbox.jar `cat prefix`/share/apertium/;
+- cp -a lt-proc-j lt-expand-j lt-comp-j lt-validate-j `cat prefix`/bin/;
++ if [ ! -d $(DESTDIR)`cat prefix` ]; then mkdir $(DESTDIR)`cat prefix`; fi
++ if [ ! -d $(DESTDIR)`cat prefix`/share ]; then mkdir $(DESTDIR)`cat prefix`/share; fi
++ if [ ! -d $(DESTDIR)`cat prefix`/share/apertium ]; then mkdir $(DESTDIR)`cat prefix`/share/apertium; fi
++ cp dist/lttoolbox.jar $(DESTDIR)`cat prefix`/share/apertium/;
++ cp dist/lttoolbox.jar $(DESTDIR)`cat prefix`/share/apertium/;
++ if [ ! -d $(DESTDIR)`cat prefix`/bin ]; then mkdir $(DESTDIR)`cat prefix`/bin; fi
++ cp -a lt-proc-j lt-expand-j lt-comp-j lt-validate-j $(DESTDIR)`cat prefix`/bin/;
+
+ tests:
+ ant -quiet test
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1152f8435ff0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Kevin Brubeck Unhammer <unhammer@gmail.com>
+# Maintainer: Kevin Brubeck Unhammer <unhammer@gmail.com>
+pkgname=lttoolbox-java
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Java port of lttoolbox. Handles lexical processing, morphological analysis and generation of words in natural languages using fast finite state transducers."
+url="http://wiki.apertium.org/wiki/Lttoolbox-java"
+license=('GPL2')
+makedepends=('apache-ant')
+depends=('java-runtime' 'sh')
+options=('!libtool')
+arch=('i686' 'x86_64')
+source=(http://downloads.sourceforge.net/sourceforge/apertium/${pkgname}-${pkgver}.tar.gz
+ 'Makefile.patch')
+md5sums=('6e029b981a721c6ad515d879e4a6478a'
+ '2304c7390728fea1b8d0ba2cce2bd780')
+
+build() {
+ patch -p0 < Makefile.patch
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./autogen.sh --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+ # There is some bug in the released source; so use the pre-packaged
+ # one instead (this is fixed upstream though, waiting for new release):
+ cp lttoolbox.jar $pkgdir/usr/share/apertium
+} \ No newline at end of file