summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-06-17 18:23:43 +0200
committerMartchus2020-06-17 18:27:28 +0200
commit3c253d16c5f0375eddb197dd5ef53bb0b7e44022 (patch)
tree09297ce432f2c504cdfbeba38736daf354c19127
downloadaur-ltunify.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab86be869019
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ltunify
+ pkgdesc = Tool for working with Logitech Unifying receivers and devices
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://lekensteyn.nl/logitech-unifying.html
+ arch = i686
+ arch = x86_64
+ license = unknown
+ source = ltunify-0.3.tar.gz::https://github.com/Lekensteyn/ltunify/archive/v0.3.tar.gz
+ md5sums = 28544d387d000a728282f8647feb90d6
+
+pkgname = ltunify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..552b878eb367
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=ltunify
+pkgver=0.3
+pkgrel=1
+pkgdesc='Tool for working with Logitech Unifying receivers and devices'
+arch=('i686' 'x86_64')
+url='https://lekensteyn.nl/logitech-unifying.html'
+license=('unknown')
+depends=()
+makedepends=()
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Lekensteyn/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('28544d387d000a728282f8647feb90d6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make ltunify
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 ltunify "$pkgdir/usr/bin/ltunify"
+ install -Dm644 udev/42-logitech-unify-permissions.rules "$pkgdir/usr/lib/udev/rules.d/42-ltunify-permissions.rules"
+}
+