summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-06 10:48:05 +0300
committerCaleb Maclennan2020-08-06 10:48:05 +0300
commit24928c0607e4e839064c50435f070ea2173f6e61 (patch)
treef3c56fad94ccc2e02cda65a7c57d0cd59f52ec38
parent0fc0f5e27f113e583248bf342fec7e718b806374 (diff)
downloadaur-24928c0607e4e839064c50435f070ea2173f6e61.tar.gz
upgpkg: lua-busted 2.0.0-9
Bump default to Lua 5.4 and add Lua 5.3 split package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 31 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a07c21e76b87..99bf529e2c73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = lua-busted
pkgdesc = Elegant Lua unit testing
pkgver = 2.0.0
- pkgrel = 8
+ pkgrel = 9
url = https://olivinelabs.com/busted
arch = any
license = MIT
makedepends = lua
+ makedepends = lua53
makedepends = lua52
makedepends = lua51
makedepends = luarocks
@@ -24,6 +25,18 @@ pkgname = lua-busted
depends = lua-system
depends = lua-term
+pkgname = lua53-busted
+ depends = lua53
+ depends = lua53-cliargs
+ depends = lua53-dkjson
+ depends = lua53-filesystem
+ depends = lua53-luassert
+ depends = lua53-mediator
+ depends = lua53-penlight
+ depends = lua53-say
+ depends = lua53-system
+ depends = lua53-term
+
pkgname = lua52-busted
depends = lua52
depends = lua52-cliargs
diff --git a/PKGBUILD b/PKGBUILD
index a90202c21245..8732c7d7e201 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
_rockname=busted
-pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=2.0.0
_rockrel=1
__rockrel=0
-pkgrel=8
+pkgrel=9
pkgdesc='Elegant Lua unit testing'
arch=('any')
url="https://olivinelabs.com/$_rockname"
license=('MIT')
-_lua_deps=('cliargs' 'dkjson' 'filesystem' 'luassert' 'mediator' 'penlight' 'say' 'system' 'term')
-makedepends=('lua' 'lua52' 'lua51' 'luarocks')
+_lua_deps=('cliargs'
+ 'dkjson'
+ 'filesystem'
+ 'luassert'
+ 'mediator'
+ 'penlight'
+ 'say'
+ 'system'
+ 'term')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("${_rockname}-${pkgver}.tar.gz::https://github.com/Olivine-Labs/$_rockname/archive/v$pkgver.tar.gz")
sha256sums=('fda34db8cd10142d2a88d6df638a7d0874c295fd2bd6338c745cc546dc5847df')
@@ -24,6 +32,11 @@ _package_helper() {
package_lua-busted() {
depends+=('lua' "${_lua_deps[@]/#/lua-}")
+ _package_helper 5.4
+}
+
+package_lua53-busted() {
+ depends+=('lua53' "${_lua_deps[@]/#/lua53-}")
_package_helper 5.3
}