summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-09-02 20:57:00 +0300
committerCaleb Maclennan2019-09-02 20:57:00 +0300
commit7e93528c1fb73644d1a392c06c4610dc1bec4f33 (patch)
tree72aa5f2c86ff795d4076c156bca1a4f2564bc4b5
parent79f33f6799d85e465c72822f46841d497e109f08 (diff)
downloadaur-7e93528c1fb73644d1a392c06c4610dc1bec4f33.tar.gz
Add missing dependency
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46911b39ecfe..dc8be9887410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lua-busted
pkgdesc = Elegant Lua unit testing.
pkgver = 2.0.0
- pkgrel = 2
+ pkgrel = 3
url = http://olivinelabs.com/busted/
arch = i686
arch = x86_64
@@ -9,13 +9,14 @@ pkgbase = lua-busted
makedepends = luarocks
depends = lua
depends = lua-cliargs
- depends = lua-filesystem
depends = lua-dkjson
- depends = lua-say
+ depends = lua-filesystem
depends = lua-luassert
- depends = lua-term
- depends = lua-penlight
depends = lua-mediator
+ depends = lua-penlight
+ depends = lua-say
+ depends = lua-system
+ depends = lua-term
source = https://luarocks.org/busted-2.0.0-1.rockspec
sha256sums = 7cb1d99772b5c7df08f7798ffb0e5b06c392a778f6b1ab923dc6d02e57497c31
diff --git a/PKGBUILD b/PKGBUILD
index fb2b2b8cf1a9..4922ab136227 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,13 @@ pkgname=lua-busted
pkgver=2.0.0
_rockname=busted
_rockrel=1
-pkgrel=2
+pkgrel=3
pkgdesc="Elegant Lua unit testing."
arch=('i686' 'x86_64')
url="http://olivinelabs.com/busted/"
license=('MIT')
-depends=('lua'
- 'lua-cliargs'
- 'lua-filesystem'
- 'lua-dkjson'
- 'lua-say'
- 'lua-luassert'
- 'lua-term'
- 'lua-penlight'
- 'lua-mediator')
+_lua_deps=('cliargs' 'dkjson' 'filesystem' 'luassert' 'mediator' 'penlight' 'say' 'system' 'term')
+depends=('lua' "${_lua_deps[@]/#/lua-}")
makedepends=('luarocks')
conflicts=()
source=("https://luarocks.org/$_rockname-$pkgver-$_rockrel.rockspec")