summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-06 13:29:20 +0300
committerCaleb Maclennan2020-02-06 13:34:48 +0300
commitd48fe8b552ef72a50040df4eaed12ab69745e7bd (patch)
tree4d05c80ff1fb76e125fadb606450b1ce85d304cc
parentca263b6992611a847ae873076953df89129c0920 (diff)
downloadaur-d48fe8b552ef72a50040df4eaed12ab69745e7bd.tar.gz
Remove AUR build path from binary, unconflict exectuables
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7be4521dcc0..f4cc10d03147 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lua-busted
pkgdesc = Elegant Lua unit testing.
pkgver = 2.0.0
- pkgrel = 5
+ pkgrel = 6
url = https://olivinelabs.com/busted
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7ddadb8626b8..76c8389e063e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,8 @@ _rockname=busted
pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=2.0.0
_rockrel=1
-pkgrel=5
+__rockrel=0
+pkgrel=6
pkgdesc='Elegant Lua unit testing.'
arch=('i686' 'x86_64')
url="https://olivinelabs.com/$_rockname"
@@ -16,7 +17,8 @@ sha256sums=('fda34db8cd10142d2a88d6df638a7d0874c295fd2bd6338c745cc546dc5847df')
_package_helper() {
cd "$_rockname-$pkgver"
- luarocks --lua-version=$1 --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "$_rockname-scm-$_rockrel.rockspec"
+ luarocks --lua-version=$1 --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "rockspecs/$_rockname-$pkgver-$__rockrel.rockspec"
+ find "$pkgdir/usr/bin" -type f -execdir sed -i -e "s#$pkgdir##" {} \;
}
package_lua-busted() {
@@ -27,9 +29,11 @@ package_lua-busted() {
package_lua52-busted() {
depends+=('lua52' "${_lua_deps[@]/#/lua52-}")
_package_helper 5.2
+ mv "$pkgdir"/usr/bin/busted{,52}
}
package_lua51-busted() {
depends+=('lua51' "${_lua_deps[@]/#/lua51-}")
_package_helper 5.1
+ mv "$pkgdir"/usr/bin/busted{,51}
}