summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre `Zopieux` Macabies2015-06-20 21:06:16 +0200
committerAlexandre `Zopieux` Macabies2015-06-20 21:06:16 +0200
commit6d2e8f644c141c1b59a0f97262941e41f8a7f64f (patch)
tree8c4be6e3736e2fa9c75fcad3625907943991c3bf
downloadaur-6d2e8f644c141c1b59a0f97262941e41f8a7f64f.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56f5e1f2394c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lua-cjson
+ pkgdesc = A fast JSON parsing and encoding support for Lua.
+ pkgver = 2.1.0
+ pkgrel = 3
+ url = http://www.kyne.com.au/~mark/software/lua-cjson.php
+ arch = i686
+ arch = x86_64
+ license = custom:MIT
+ depends = lua
+ optdepends = perl: UTF8 implementation test
+ source = http://www.kyne.com.au/~mark/software/download/lua-cjson-2.1.0.tar.gz
+ md5sums = 24f270663e9f6ca8ba2a02cef19f7963
+
+pkgname = lua-cjson
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b51281d3edfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: zopieux <web+oss at zopieux dot com>
+
+_lua_version=5.3
+
+pkgname=lua-cjson
+pkgver=2.1.0
+pkgrel=3
+pkgdesc="A fast JSON parsing and encoding support for Lua."
+arch=(i686 x86_64)
+url="http://www.kyne.com.au/~mark/software/lua-cjson.php"
+license=('custom:MIT')
+depends=("lua")
+optdepends=('perl: UTF8 implementation test')
+source=("http://www.kyne.com.au/~mark/software/download/$pkgname-$pkgver.tar.gz")
+md5sums=('24f270663e9f6ca8ba2a02cef19f7963')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr LUA_INCLUDE_DIR=/usr/include/lua${_lua_version} LUA_VERSION=${_lua_version}
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir/" LUA_INCLUDE_DIR=/usr/include/lua${_lua_version} LUA_VERSION=${_lua_version} install{,-extra}
+
+ # license
+ install -Dm644 LICENSE \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: