summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Smith2019-01-27 18:30:49 -0500
committerStephen Smith2019-01-27 18:30:49 -0500
commit9c1b18816468849b08fc055687e505790e670239 (patch)
tree7078631f51a1b33c7dcf15851300fce7a30eaf08
parent39029759210584b21de1415a814d4eaf2a53aa69 (diff)
downloadaur-9c1b18816468849b08fc055687e505790e670239.tar.gz
Split package to add lua 5.1 and 5.2
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 44 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b76aa7a2624..b2bc2c63629e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 26 02:56:13 UTC 2019
+# Sun Jan 27 23:30:15 UTC 2019
pkgbase = lua-copas
pkgdesc = Copas is a dispatcher based on coroutines that can be used by TCP/IP servers.
pkgver = 2.0.2
@@ -8,12 +8,24 @@ pkgbase = lua-copas
arch = i686
arch = x86_64
license = MIT
- makedepends = luarocks
- depends = lua
- depends = lua-luasocket
- depends = lua-coxpcall
source = copas-2.0.2.tar.gz::https://github.com/keplerproject/copas/archive/2.0.2.tar.gz
md5sums = dfb5969f077b4bf9a222a3c532400b45
pkgname = lua-copas
+ depends = lua
+ depends = lua-socket
+ depends = lua-coxpcall
+ depends = luarocks
+
+pkgname = lua51-copas
+ depends = lua51
+ depends = lua51-socket
+ depends = lua51-coxpcall
+ depends = luarocks5.1
+
+pkgname = lua52-copas
+ depends = lua52
+ depends = lua52-socket
+ depends = lua52-coxpcall
+ depends = luarocks5.2
diff --git a/PKGBUILD b/PKGBUILD
index cdb54646461d..38b506bc8c32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Stephen Smith <stephen304@gmail.com>
-pkgname=lua-copas
+pkgname=('lua-copas' 'lua51-copas' 'lua52-copas')
+pkgbase=lua-copas
_rockname=copas
pkgver=2.0.2
pkgrel=1
@@ -8,18 +9,35 @@ pkgdesc="Copas is a dispatcher based on coroutines that can be used by TCP/IP se
arch=('i686' 'x86_64')
url="http://keplerproject.github.io/copas"
license=('MIT')
-depends=('lua' 'lua-luasocket' 'lua-coxpcall')
-makedepends=('luarocks')
-conflicts=()
source=("${_rockname}-${pkgver}.tar.gz::https://github.com/keplerproject/${_rockname}/archive/${pkgver}.tar.gz")
md5sums=('dfb5969f077b4bf9a222a3c532400b45')
-build() {
+_package_helper() {
+ _lua_ver=$1
+
+ mkdir -p "$_lua_ver"
cd "$_rockname-$pkgver"
- luarocks make --pack-binary-rock --deps-mode=none "rockspec/$_rockname-$pkgver-1.rockspec"
-}
+ luarocks-${_lua_ver} make --pack-binary-rock --deps-mode=none "rockspec/$_rockname-$pkgver-1.rockspec"
+ mv *.rock ../${_lua_ver}/
-package() {
- luarocks install --tree="$pkgdir/usr/" --deps-mode=none "$_rockname-$pkgver"/*.rock
+ luarocks-${_lua_ver} install --tree="$pkgdir/usr/" --deps-mode=none ../${_lua_ver}/*.rock
find "$pkgdir/usr" -name manifest -delete
}
+
+package_lua51-copas() {
+ depends=('lua51' 'lua51-socket' 'lua51-coxpcall' 'luarocks5.1')
+
+ _package_helper "5.1"
+}
+
+package_lua52-copas() {
+ depends=('lua52' 'lua52-socket' 'lua52-coxpcall' 'luarocks5.2')
+
+ _package_helper "5.2"
+}
+
+package_lua-copas() {
+ depends=('lua' 'lua-socket' 'lua-coxpcall' 'luarocks')
+
+ _package_helper "5.3"
+}