summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvy Foster2017-10-26 20:57:35 -0500
committerIvy Foster2017-10-26 20:57:35 -0500
commit86570a006381f3c00815e3a39ec808cf45922fd3 (patch)
tree1c9b9e50df6e52ab1a8207d67431db24b1e4ce04
downloadaur-86570a006381f3c00815e3a39ec808cf45922fd3.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94479cc42e2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lua-cosmo-git
+ pkgdesc = Safe templates for Lua
+ pkgver = 16.06.04
+ pkgrel = 1
+ url = http://cosmo.luaforge.net/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = luarocks
+ depends = lua
+ depends = lua-lpeg
+ provides = lua-cosmo
+ conflicts = lua-cosmo
+ source = git+https://github.com/mascarenhas/cosmo.git
+ md5sums = SKIP
+
+pkgname = lua-cosmo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cde3f65011a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Ivy Foster <code@escondida.tk>
+
+pkgname=lua-cosmo-git
+pkgver=16.06.04
+pkgrel=1
+pkgdesc='Safe templates for Lua'
+arch=(i686 x86_64)
+url='http://cosmo.luaforge.net/'
+license=(MIT)
+
+depends=(lua lua-lpeg)
+makedepends=(luarocks)
+
+provides=(lua-cosmo)
+conflicts=(lua-cosmo)
+
+source=('git+https://github.com/mascarenhas/cosmo.git')
+md5sums=(SKIP)
+
+package() {
+ luarocks --tree="$pkgdir/usr" install --deps-mode=none cosmo
+ find "$pkgdir/usr" -name manifest -delete
+}