summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaurnimator2018-09-23 20:46:51 +1000
committerdaurnimator2018-09-23 20:46:51 +1000
commitd5adf07b79e1ae4e651b3969830fea6afbacd842 (patch)
tree0d7ca0442b06429b7caa50d59910bd6643ea6304
parent776817370811d820e4005ca0216589128e93c072 (diff)
downloadaur-d5adf07b79e1ae4e651b3969830fea6afbacd842.tar.gz
Use pkgname prefixed tarball to allow a shared SRCDEST
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD29
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5aeb6f711cd9..6b48033d7f85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = lua-cqueues
pkgver = 20171014
- pkgrel = 0
+ pkgrel = 1
url = http://25thandclement.com/~william/projects/cqueues.html
- arch = i686
arch = x86_64
license = MIT
makedepends = lua
makedepends = lua51
makedepends = lua52
depends = openssl
- source = https://github.com/wahern/cqueues/archive/rel-20171014.tar.gz
+ source = lua-cqueues-20171014.tar.gz::https://github.com/wahern/cqueues/archive/rel-20171014.tar.gz
md5sums = d3912ad77724b223e24d1ba55e9a9293
pkgname = lua-cqueues
diff --git a/PKGBUILD b/PKGBUILD
index aea59e10c29d..f00331ba0c56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,41 @@
# Maintainer: Daurnimator <quae@daurnimator.com>
-pkgname=(lua-cqueues lua51-cqueues lua52-cqueues)
+pkgname=('lua-cqueues' 'lua51-cqueues' 'lua52-cqueues')
pkgver=20171014
-pkgrel=0
-arch=('i686' 'x86_64')
+pkgrel=1
+arch=('x86_64')
url='http://25thandclement.com/~william/projects/cqueues.html'
license=('MIT')
makedepends=('lua' 'lua51' 'lua52')
depends=('openssl')
-source=('https://github.com/wahern/cqueues/archive/rel-20171014.tar.gz')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wahern/cqueues/archive/rel-$pkgver.tar.gz")
md5sums=('d3912ad77724b223e24d1ba55e9a9293')
+
build() {
- cd cqueues-rel-20171014;
+ cd "cqueues-rel-$pkgver"
make prefix=/usr
}
package_lua-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.3'
- cd cqueues-rel-20171014;
- make DESTDIR=${pkgdir} prefix=/usr install5.3
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd "cqueues-rel-$pkgver"
+ make DESTDIR="$pkgdir" prefix=/usr install5.3
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_lua51-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.1'
- cd cqueues-rel-20171014;
- make DESTDIR=${pkgdir} prefix=/usr install5.1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd "cqueues-rel-$pkgver"
+ make DESTDIR="$pkgdir" prefix=/usr install5.1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_lua52-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.2'
- cd cqueues-rel-20171014;
- make DESTDIR=${pkgdir} prefix=/usr install5.2
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd "cqueues-rel-$pkgver"
+ make DESTDIR="$pkgdir" prefix=/usr install5.2
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}