summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Heywood2016-02-29 00:21:01 -0600
committerCharles Heywood2016-02-29 00:22:32 -0600
commita1fc1445f4fa01f598a484088a0f14728c9945ad (patch)
tree3fa8fb731017406e0c948c2c941ed3cf17798778
downloadaur-a1fc1445f4fa01f598a484088a0f14728c9945ad.tar.gz
Add initial PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dda9cd09099f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lua-cqueues-git
+ pkgdesc = Asynchronous networking, threading, and notification framework for Lua.
+ pkgver = 20150907
+ pkgrel = 1
+ url = https://github.com/wahern/cqueues
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = m4
+ depends = openssl
+ source = git+https://github.com/wahern/cqueues.git#branch=master
+ md5sums = SKIP
+
+pkgname = lua-cqueues-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a21fec1b9c91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Charles Heywood <charles@hashbang.sh>
+pkgname=lua-cqueues-git
+pkgver=20150907 # As per latest release as of 29 Feb. 2016
+pkgrel=1
+pkgdesc="Asynchronous networking, threading, and notification framework for Lua."
+arch=('i686' 'x86_64')
+url="https://github.com/wahern/cqueues"
+license=('MIT')
+depends=('m4' 'openssl')
+makedepends=('git')
+source=('git+https://github.com/wahern/cqueues.git#branch=master')
+md5sums=('SKIP')
+_luaversions=('5.1' '5.2' '5.3')
+pkgver() {
+ cd "$srcdir/cqueues"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+build() {
+ cd "$srcdir/cqueues"
+ for version in ${_luaversions[@]}; do
+ echo "*** Attempting build for Lua version: $version"
+ make cqueues${version}
+ done
+}
+package() {
+ cd "$srcdir/cqueues"
+ for version in ${_luaversions[@]}; do
+ make DESTDIR="$pkgdir/" install${version}
+ done
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+# vim:set et sts=0 sw=2 ts=2: