summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-13 19:12:29 +0300
committerDimitris Kiziridis2020-05-13 19:12:29 +0300
commit244a24dc3f53ceaa45271fefc8a09148db49aa25 (patch)
treeee9cfb399b14dff7bea322157498aef2d713312e
parent40f8c4267a319f7f85dad0b41b0268144d69b0e0 (diff)
downloadaur-244a24dc3f53ceaa45271fefc8a09148db49aa25.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b56bdc461684..3768e7964042 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,7 @@ pkgbase = lua-date
pkgver = 2.1.2
pkgrel = 1
url = http://tieske.github.io/date
- arch = x86_64
+ arch = any
license = MIT
makedepends = luarocks
source = https://github.com/Tieske/date/archive/version_2.1.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index d760d450cc2b..9a12d35596fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=('lua-date' 'lua51-date' 'lua52-date')
pkgver=2.1.2
pkgrel=1
pkgdesc="Date & Time module for Lua 5.x"
-arch=('x86_64')
+arch=('any')
url='http://tieske.github.io/date'
license=('MIT')
makedepends=('luarocks')
@@ -26,7 +26,7 @@ package_lua-date() {
pkgdesc='Date and Time module for Lua 5.3'
luarocks install --lua-version=5.3 --tree="$pkgdir/usr/" --deps-mode=none 5.3/*.rock
-
+ install -Dm644 "${srcdir}/date-version_${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.3/manifest"
}
@@ -35,7 +35,7 @@ package_lua51-date() {
pkgdesc='Date and Time module for Lua 5.1'
luarocks install --lua-version=5.1 --tree="$pkgdir/usr/" --deps-mode=none 5.1/*.rock
-
+ install -Dm644 "${srcdir}/date-version_${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.1/manifest"
}
@@ -44,7 +44,7 @@ package_lua52-date() {
pkgdesc='Date and Time module for Lua 5.2'
luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none 5.2/*.rock
-
+ install -Dm644 "${srcdir}/date-version_${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.2/manifest"
} \ No newline at end of file