summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-06 12:22:02 +0300
committerCaleb Maclennan2020-08-06 12:22:02 +0300
commit7d6f5f4e16c78e8087d3c286a090af8f7f229a69 (patch)
tree905e550b3e72815f219258cb1b70f77713d77e5a
parentb2b5e93555ab9c239c03e0b1ce90d04487f0ed9e (diff)
downloadaur-7d6f5f4e16c78e8087d3c286a090af8f7f229a69.tar.gz
upgpkg: lua-commonmark 0.0.0-4
upgpkg: lua-fluent 0.0.4-7 Bump default to Lua 5.4 and add Lua 5.3 split package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0051ca3552ee..6e70b595d009 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = lua-fluent
pkgdesc = Lua implementation of Project Fluent
pkgver = 0.0.4
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/alerque/fluent-lua
arch = any
license = MIT
makedepends = lua
+ makedepends = lua53
makedepends = lua52
makedepends = lua51
makedepends = luarocks
@@ -18,6 +19,12 @@ pkgname = lua-fluent
depends = lua-luaepnf
depends = lua-penlight
+pkgname = lua53-fluent
+ depends = lua53
+ depends = lua53-cldr
+ depends = lua53-luaepnf
+ depends = lua53-penlight
+
pkgname = lua52-fluent
depends = lua52
depends = lua52-cldr
diff --git a/PKGBUILD b/PKGBUILD
index f6d5852a0695..b0ef286fcb70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_rockname=fluent
_project=$_rockname-lua
-pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=0.0.4
_rockrel=0
-pkgrel=6
+pkgrel=7
pkgdesc='Lua implementation of Project Fluent'
arch=('any')
url="https://github.com/alerque/$_project"
license=('MIT')
_lua_deps=('cldr' 'luaepnf' 'penlight')
-makedepends=('lua' 'lua52' 'lua51' 'luarocks')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("$_rockname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('90705d64e4bc35d204604601e65094da49ca14c41e43110da778c1e3166346b5')
@@ -23,6 +23,11 @@ _package_helper() {
package_lua-fluent() {
depends=('lua' "${_lua_deps[@]/#/lua-}")
+ _package_helper 5.4
+}
+
+package_lua53-fluent() {
+ depends=('lua53' "${_lua_deps[@]/#/lua53-}")
_package_helper 5.3
}