summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Klimeš2022-09-27 16:43:32 +0200
committerJiří Klimeš2022-09-27 16:43:32 +0200
commit57b89a8169b995b9ec818e37703849ba8682b6fe (patch)
tree6cb02b8e312b32dea59e1bfbd59abd5f9d24a7a5
parent83ddbc079774d0c22a5fc3792316939f5b1670fb (diff)
downloadaur-57b89a8169b995b9ec818e37703849ba8682b6fe.tar.gz
Do not use msg2 function in PKGBUILD
It is an internal function of makepkg and should not be used in PKGBUILD. https://bugs.archlinux.org/task/43502 https://wiki.archlinux.org/index.php/Arch_package_guidelines#Package_etiquette
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31d311cac2b3..2f8ab98918b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,13 +22,13 @@ prepare() {
build() {
cd "$srcdir"/luagl
- msg2 'Building with Lua 5.3'
+ echo 'Building with Lua 5.3'
make USE_LUA53=Yes RUN_PATH="-Wl,-rpath=/usr/lib/lua/5.3,--enable-new-dtags,--as-needed"
- msg2 'Building with Lua 5.1'
+ echo 'Building with Lua 5.1'
make USE_LUA51=Yes RUN_PATH="-Wl,-rpath=/usr/lib/lua/5.1,--enable-new-dtags,--as-needed"
- msg2 'Building with Lua 5.2'
+ echo 'Building with Lua 5.2'
make USE_LUA52=Yes RUN_PATH="-Wl,-rpath=/usr/lib/lua/5.2,--enable-new-dtags,--as-needed"
}