summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelix2017-01-24 13:57:08 +0100
committerfelix2017-01-24 13:58:04 +0100
commit2f9206f1f0f5ffaf1c26fcb5bdb4379225187eb5 (patch)
tree4353e84a1d3fbfb2ee26c88876b2d77721d294e2
parent7dc5442806ae73ee55c796b59b26ba216eaea77a (diff)
downloadaur-2f9206f1f0f5ffaf1c26fcb5bdb4379225187eb5.tar.gz
Switch to direct building
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5772f982a2f5..2842e17a3f35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = lua-iconv
pkgdesc = Lua bindings for the iconv API
pkgver = 7
- pkgrel = 1
+ pkgrel = 2
url = http://ittner.github.com/lua-iconv/
arch = i686
arch = x86_64
license = custom
- makedepends = luarocks
depends = lua
- source = https://luarocks.org/lua-iconv-7-1.src.rock
- sha512sums = 88046ca7aec54993c64a1cd6d5a2c6a7793a3987b21d37441ad23bb3af229b3cd28385b73cd99f9351a3362b7219709bad762f401c70926f0dbbe5efd7a61e8e
+ source = https://github.com/downloads/ittner/lua-iconv/lua-iconv-7.tar.gz
+ source = https://github.com/downloads/ittner/lua-iconv/lua-iconv-7.tar.gz.sig
+ validpgpkeys = 9B49FCE2E6B9D1AD610129AD4F6DF1140041A1FB
+ sha512sums = 03b537ba6050ca8e59e6a62474e837c0d6463d1da4610e6da820afc573659571f75de0c7507792e8b7348fd91623d7af7050ead18bd09ec0c7b89a742e024a57
+ sha512sums = SKIP
pkgname = lua-iconv
diff --git a/PKGBUILD b/PKGBUILD
index 411a54fe87a1..f0b073f59f2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
pkgname=lua-iconv
pkgver=7
-pkgrel=1
+pkgrel=2
pkgdesc="Lua bindings for the iconv API"
arch=('i686' 'x86_64')
url="http://ittner.github.com/lua-iconv/"
license=('custom')
depends=('lua')
-makedepends=('luarocks')
conflicts=()
-source=("https://luarocks.org/$pkgname-$pkgver-$pkgrel.src.rock")
-sha512sums=('88046ca7aec54993c64a1cd6d5a2c6a7793a3987b21d37441ad23bb3af229b3cd28385b73cd99f9351a3362b7219709bad762f401c70926f0dbbe5efd7a61e8e')
+source=(
+ "https://github.com/downloads/ittner/lua-iconv/lua-iconv-$pkgver.tar.gz"
+ "https://github.com/downloads/ittner/lua-iconv/lua-iconv-$pkgver.tar.gz.sig"
+)
+sha512sums=(
+ '03b537ba6050ca8e59e6a62474e837c0d6463d1da4610e6da820afc573659571f75de0c7507792e8b7348fd91623d7af7050ead18bd09ec0c7b89a742e024a57'
+ 'SKIP'
+)
+validpgpkeys=('9B49FCE2E6B9D1AD610129AD4F6DF1140041A1FB') # Alexandre Erwin Ittner <FIRST_NAME@LAST_NAME.com.br>
-package() {
- luarocks --tree="$pkgdir/usr" install "$pkgname-$pkgver-$pkgrel.src.rock"
+build() {
+ cd "$srcdir/lua-iconv-$pkgver"
+ make LUAPKG=lua53
+}
- mkdir -p "$pkgdir/usr/share/doc"
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
- mv "$pkgdir/usr/lib/luarocks/rocks-"*"/lua-iconv/$pkgver-$pkgrel/doc/README" "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/lib/luarocks/rocks-"*"/lua-iconv/$pkgver-$pkgrel/doc/COPYING" "$pkgdir/usr/share/licenses/$pkgname"
- rm -rf "$pkgdir/usr/lib/luarocks"
+package() {
+ cd "$srcdir/lua-iconv-$pkgver"
+ install -Dm0644 iconv.so "$pkgdir/usr/lib/lua/5.3/iconv.so"
+ install -Dm0644 README "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm0644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}