summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Smith2019-01-26 15:52:48 -0500
committerStephen Smith2019-01-26 15:52:48 -0500
commit87d1a731ca7d6fc8e43fc4877052959eb0590f4e (patch)
treea7900bd39f0d0971f0a94c5d3112ff3c44ecc206
downloadaur-87d1a731ca7d6fc8e43fc4877052959eb0590f4e.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b575714c561a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Jan 26 20:52:16 UTC 2019
+pkgbase = lua-jsonrpc4lua
+ pkgdesc = A very basic JSON RPC client and server-side module. This repository is a fork of the original craigmj/json4lua repository with bug fixes and the switch to lua-cjson for JSON encoding and decoding.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/pdxmeshnet/jsonrpc4lua
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = luarocks
+ depends = lua
+ depends = lua-luasocket
+ depends = lua-cgilua-git
+ depends = lua-cjson
+ optdepends = lua-xavante: Optional requirement to run the server-side example
+ source = jsonrpc4lua-1.0.1.tar.gz::https://github.com/pdxmeshnet/jsonrpc4lua/archive/1.0.1.tar.gz
+ md5sums = 7b885a8d07bbcc84f7380cd1e9e32016
+
+pkgname = lua-jsonrpc4lua
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f43408914252
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Stephen Smith <stephen304@gmail.com>
+
+pkgname=lua-jsonrpc4lua
+_rockname=jsonrpc4lua
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A very basic JSON RPC client and server-side module. This repository is a fork of the original craigmj/json4lua repository with bug fixes and the switch to lua-cjson for JSON encoding and decoding."
+arch=('i686' 'x86_64')
+url="https://github.com/pdxmeshnet/jsonrpc4lua"
+license=('GPL')
+depends=('lua' 'lua-luasocket' 'lua-cgilua-git' 'lua-cjson')
+optdepends=('lua-xavante: Optional requirement to run the server-side example')
+makedepends=('luarocks')
+conflicts=()
+source=("${_rockname}-${pkgver}.tar.gz::https://github.com/pdxmeshnet/${_rockname}/archive/${pkgver}.tar.gz")
+md5sums=('7b885a8d07bbcc84f7380cd1e9e32016')
+
+build() {
+ cd "$_rockname-$pkgver"
+ luarocks make --pack-binary-rock --deps-mode=none "$_rockname-$pkgver-1.rockspec"
+}
+
+package() {
+ luarocks install --tree="$pkgdir/usr/" --deps-mode=none "$_rockname-$pkgver"/*.rock
+ find "$pkgdir/usr" -name manifest -delete
+}