summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2018-03-30 00:20:57 +0200
committerosch2018-03-30 00:20:57 +0200
commit7ad1a6bce611c5ebf46e1b1ca1036f840f733be2 (patch)
treeffcd6584f66b40e81a4a0e2e58419b0a23670c62
downloadaur-7ad1a6bce611c5ebf46e1b1ca1036f840f733be2.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e65773b6c07f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lua-lanes-git
+ pkgdesc = A solution for running Lua multithreaded
+ pkgver = 3.11.r10.95ca27b
+ pkgrel = 1
+ url = https://github.com/LuaLanes/lanes
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = lua
+ provides = lua-lanes
+ conflicts = lua-lanes
+ source = lua-lanes::git+https://github.com/LuaLanes/lanes.git
+ md5sums = SKIP
+
+pkgname = lua-lanes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..007c8882c499
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: osch <oliver at luced de>
+pkgname=lua-lanes-git
+pkgver=3.11.r10.95ca27b
+pkgrel=1
+pkgdesc="A solution for running Lua multithreaded"
+arch=('x86_64')
+url="https://github.com/LuaLanes/lanes"
+license=('MIT')
+groups=()
+depends=('lua')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname%-git}::git+https://github.com/LuaLanes/lanes.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//')"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ sed -i -e '1s/^/struct s_Universe;\n/' src/tools.h
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make LUA=/usr/bin/lua \
+ LUA_FLAGS=`pkg-config --cflags lua` \
+ LUA_LIBS=`pkg-config --libs lua` \
+ CFLAGS="-O2 -fPIC `pkg-config --cflags lua`"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+
+ install -d "$pkgdir`pkg-config --variable=INSTALL_CMOD lua`/lanes"
+ install src/lanes/core.so "$pkgdir`pkg-config --variable=INSTALL_CMOD lua`/lanes/core.so"
+
+ install -d "$pkgdir`pkg-config --variable=INSTALL_LMOD lua`"
+ install -m644 src/lanes.lua "$pkgdir`pkg-config --variable=INSTALL_LMOD lua`"
+
+ install -d "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ install -m644 COPYRIGHT "$pkgdir/usr/share/licenses/${pkgname%-git}"
+}
+md5sums=('SKIP')