summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-05-15 12:56:48 +0300
committerCaleb Maclennan2020-05-15 12:56:48 +0300
commit64d89361104988e0e4ae4127ce57a67332c28c72 (patch)
tree014c9b1290dcdc0a78cbe48832914f5f37e18bae
parentebf8df32d5570d39f82cc56b20a6bf916f92b36e (diff)
downloadaur-64d89361104988e0e4ae4127ce57a67332c28c72.tar.gz
Fix makedepends, all Lua versions required to make split packages
upgpkg: lua-busted 2.0.0-8 upgpkg: lua-cliargs 3.0-4 upgpkg: lua-colors 8.05.26-3 upgpkg: lua-copas 2.0.2-2 upgpkg: lua-cosmo 16.06.04-3 upgpkg: lua-coxpcall 1.16.0-2 upgpkg: lua-dkjson 2.5-3 upgpkg: lua-lcf 5.3-2 upgpkg: lua-linenoise 0.9-4 upgpkg: lua-lsqlite3 0.9.5-3 upgpkg: lua-luacov-coveralls 0.2.2-3 upgpkg: lua-luacov 0.14.0-4 upgpkg: lua-luassert 1.8.0-5 upgpkg: lua-lub 1.1.0-3 upgpkg: lua-mediator 1.1.2-3 upgpkg: lua-path 0.3.1-3 upgpkg: lua-pegdebug 0.41-3 upgpkg: lua-repl 0.9-4 upgpkg: lua-say 1.3-4 upgpkg: lua-serpent 0.28-3 upgpkg: lua-std-_debug 1.0.1-3 upgpkg: lua-std-normalize 2.0.3-2 upgpkg: lua-stdlib 41.2.2-4 upgpkg: lua-vstruct 2.1.1-2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9865af2adde3..79ebd45050ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = lua-lsqlite3
pkgdesc = A binding for Lua to the SQLite3 database library
pkgver = 0.9.5
- pkgrel = 2
+ pkgrel = 3
url = http://lua.sqlite.org
arch = i686
arch = x86_64
license = MIT
+ makedepends = lua
+ makedepends = lua52
+ makedepends = lua51
makedepends = luarocks
depends = sqlite
source = lsqlite3-0.9.5.zip::http://lua.sqlite.org/index.cgi/zip/lsqlite3_fsl09y.zip?uuid=fsl_9y
diff --git a/PKGBUILD b/PKGBUILD
index 94f32cb10b78..e4874a5136db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,20 @@ pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=0.9.5
_fossilver=fsl09y
_rockrel=1
-pkgrel=2
-pkgdesc="A binding for Lua to the SQLite3 database library"
+pkgrel=3
+pkgdesc='A binding for Lua to the SQLite3 database library'
arch=('i686' 'x86_64')
url='http://lua.sqlite.org'
license=('MIT')
depends=('sqlite')
-makedepends=('luarocks')
+makedepends=('lua' 'lua52' 'lua51' 'luarocks')
source=("$_rockname-$pkgver.zip::http://lua.sqlite.org/index.cgi/zip/lsqlite3_$_fossilver.zip?uuid=${_fossilver/0/_}")
sha256sums=('72498d89056ada0d03a2053224dc887bf7535eb75d006232be14ef7824848818')
_package_helper() {
cd "${_rockname}_$_fossilver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
+ luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
}
package_lua-lsqlite3() {