summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2016-12-05 14:19:25 +0300
committerCaleb Maclennan2019-06-18 15:10:19 +0300
commita819ebeedbefa41ea1e0b484f84565d06f327b08 (patch)
tree7d6e00fe929001e8046137915c1518b287d3bb1b
downloadaur-a819ebeedbefa41ea1e0b484f84565d06f327b08.tar.gz
Add initial PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb019fbc59bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lua-luacov
+ pkgdesc = Coverage analysis tool for Lua scripts
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://keplerproject.github.io/luacov/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = luarocks
+ depends = lua
+ source = https://luarocks.org/luacov-0.8-1.src.rock
+ sha256sums = f92229ee0ec8ce285e749ede4a9f2f2efa7460d8fee0ad28299f87a45a181ab8
+
+pkgname = lua-luacov
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0ca50ff4dd97
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!./.SRCINFO
+!./.gitignore
+!./PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be68d7c56c07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=lua-luacov
+pkgver=0.8
+_rockname=luacov
+_rockrel=1
+pkgrel=1
+pkgdesc="Coverage analysis tool for Lua scripts"
+arch=('i686' 'x86_64')
+url="http://keplerproject.github.io/luacov/"
+license=('MIT')
+depends=('lua')
+makedepends=('luarocks')
+conflicts=()
+source=("https://luarocks.org/$_rockname-$pkgver-$_rockrel.src.rock")
+sha256sums=('f92229ee0ec8ce285e749ede4a9f2f2efa7460d8fee0ad28299f87a45a181ab8')
+
+package() {
+ luarocks --tree="$pkgdir/usr" install --deps-mode=none "$_rockname-$pkgver-$_rockrel.src.rock"
+ find "$pkgdir/usr" -name manifest -delete
+}