summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Cabanilla2015-06-10 19:44:55 -0400
committerCarlo Cabanilla2015-06-10 19:44:55 -0400
commit8bf2dc0b75acabd296a8c2751ab7df4f22bb9271 (patch)
treec529982d51fd88330f726d30eecc9dea47ef7440
downloadaur-8bf2dc0b75acabd296a8c2751ab7df4f22bb9271.tar.gz
imported from aur tarball
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adb263452b5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Thu May 21 02:09:17 UTC 2015
+pkgbase = lua-luafilesystem
+ pkgdesc = A lua library to access the underlying directory structure and file attributes
+ pkgver = 1.6.3
+ pkgrel = 1
+ url = http://keplerproject.github.io/luafilesystem/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = make
+ makedepends = gcc
+ depends = lua
+ source = luafilesystem-v_1_6_3.tar.gz::https://github.com/keplerproject/luafilesystem/archive/v_1_6_3.tar.gz
+ md5sums = d0552c7e5a082f5bb2865af63fb9dc95
+
+pkgname = lua-luafilesystem
+
+pkgname = lua52-luafilesystem
+
+pkgname = lua51-luafilesystem
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c01bc60c67d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Carlo Cabanilla <carlo.cabanilla@gmail.com>
+pkgname=(lua-luafilesystem lua52-luafilesystem lua51-luafilesystem)
+pkgver=1.6.3
+_tag=v_${pkgver//./_}
+pkgrel=1
+pkgdesc="A lua library to access the underlying directory structure and file attributes"
+arch=(i686 x86_64)
+url="http://keplerproject.github.io/luafilesystem/"
+license=('MIT')
+depends=(lua)
+makedepends=(make gcc)
+install=
+changelog=
+source=("luafilesystem-${_tag}.tar.gz::https://github.com/keplerproject/luafilesystem/archive/${_tag}.tar.gz")
+md5sums=('d0552c7e5a082f5bb2865af63fb9dc95')
+
+build() {
+ cd "luafilesystem-${_tag}"
+ make
+}
+
+package() {
+ _luaver=$1
+ cd "luafilesystem-${_tag}"
+ export PREFIX=${pkgdir}/usr
+ export LUA_LIBDIR=${PREFIX}/lib/lua/${_luaver}
+ make -e install
+}
+
+package_lua-luafilesystem() {
+ package 5.3
+}
+
+package_lua52-luafilesystem() {
+ package 5.2
+}
+
+package_lua51-luafilesystem() {
+ package 5.1
+}