summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Regan2020-12-28 13:11:17 -0500
committerJohn Regan2020-12-28 13:11:17 -0500
commit48648766f39d71cb4ae7698fd86e14063369b891 (patch)
treebffeba2921597a581893d886ad374fafab9375e4
parentbe0cf64798136ae54a48daf52e84f3be7f9faf57 (diff)
downloadaur-48648766f39d71cb4ae7698fd86e14063369b891.tar.gz
updates
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD17
2 files changed, 33 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 271030484d50..b1146a70de79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,15 @@
pkgbase = lua-luatrace-git
pkgver = r143.d9d8918
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/geoffleyland/luatrace
arch = x86_64
arch = i686
license = MIT
+ makedepends = git
+ makedepends = lua
+ makedepends = lua51
+ makedepends = lua52
+ makedepends = lua53
source = git+https://github.com/geoffleyland/luatrace.git
source = luatrace-compat.patch
source = luatrace-updates.patch
@@ -16,13 +21,25 @@ pkgbase = lua-luatrace-git
pkgname = lua-luatrace-git
pkgdesc = luatrace for Lua 5.4
+ depends = lua
+ provides = lua-luatrace
+ conflicts = lua-luatrace
pkgname = lua51-luatrace-git
pkgdesc = luatrace for Lua 5.1
+ depends = lua51
+ provides = lua51-luatrace
+ conflicts = lua51-luatrace
pkgname = lua52-luatrace-git
pkgdesc = luatrace for Lua 5.2
+ depends = lua52
+ provides = lua52-luatrace
+ conflicts = lua52-luatrace
pkgname = lua53-luatrace-git
pkgdesc = luatrace for Lua 5.3
+ depends = lua53
+ provides = lua53-luatrace
+ conflicts = lua53-luatrace
diff --git a/PKGBUILD b/PKGBUILD
index 16b8e160d388..51a4edb7f9f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,11 @@
pkgname=('lua-luatrace-git' 'lua51-luatrace-git' 'lua52-luatrace-git' 'lua53-luatrace-git')
_pkgbase='luatrace'
pkgver=r143.d9d8918
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686')
url='https://github.com/geoffleyland/luatrace'
license=('MIT')
+makedepends=('git' 'lua' 'lua51' 'lua52' 'lua53')
source=('git+https://github.com/geoffleyland/luatrace.git'
"${_pkgbase}-compat.patch"
"${_pkgbase}-updates.patch"
@@ -44,7 +45,7 @@ build() {
gcc -fPIC $CPPFLAGS $CFLAGS -I/usr/include/lua5.3 -o c/c_hook.o -c c/c_hook.c
gcc -shared $LDFLAGS -o c_hook-5.3.so c/c_hook.o
- sed 's/@LUA@/lua/' < "${srcdir}/luatrace.profile" > luatrace.profile
+ sed 's/@LUA@/lua/' < "${srcdir}/luatrace.profile" > luatrace.profile
sed 's/@LUA@/lua5.1/' < "${srcdir}/luatrace.profile" > luatrace.profile5.1
sed 's/@LUA@/lua5.2/' < "${srcdir}/luatrace.profile" > luatrace.profile5.2
sed 's/@LUA@/lua5.3/' < "${srcdir}/luatrace.profile" > luatrace.profile5.3
@@ -52,6 +53,9 @@ build() {
package_lua-luatrace-git() {
pkgdesc="luatrace for Lua 5.4"
+ provides=('lua-luatrace')
+ conflicts=('lua-luatrace')
+ depends+=('lua')
cd "${_pkgbase}"
@@ -74,6 +78,9 @@ package_lua-luatrace-git() {
package_lua51-luatrace-git() {
pkgdesc="luatrace for Lua 5.1"
+ provides=('lua51-luatrace')
+ conflicts=('lua51-luatrace')
+ depends+=('lua51')
cd "${_pkgbase}"
@@ -95,6 +102,9 @@ package_lua51-luatrace-git() {
package_lua52-luatrace-git() {
pkgdesc="luatrace for Lua 5.2"
+ provides=('lua52-luatrace')
+ conflicts=('lua52-luatrace')
+ depends+=('lua52')
cd "${_pkgbase}"
@@ -116,6 +126,9 @@ package_lua52-luatrace-git() {
package_lua53-luatrace-git() {
pkgdesc="luatrace for Lua 5.3"
+ provides=('lua53-luatrace')
+ conflicts=('lua53-luatrace')
+ depends+=('lua53')
cd "${_pkgbase}"