summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2016-12-05 14:19:25 +0300
committerCaleb Maclennan2019-06-18 15:33:40 +0300
commit62bab2bbfa99f7a7ae53bf99f6f1c427b506b0da (patch)
tree4dec8876ce27f37465ac16da4b69ce428bd2f55f
downloadaur-62bab2bbfa99f7a7ae53bf99f6f1c427b506b0da.tar.gz
Add initial PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..906e48277b82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lua-mediator
+ pkgdesc = Event handling through channels
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = http://olivinelabs.com/mediator_lua/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = luarocks
+ depends = lua
+ source = https://luarocks.org/mediator_lua-1.1.2-0.rockspec
+ sha256sums = 751debefe0aa00fa93c0ae6371922055289e9948b0231d1430c214118fdb3f3b
+
+pkgname = lua-mediator
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0ca50ff4dd97
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!./.SRCINFO
+!./.gitignore
+!./PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6838fa6716e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=lua-mediator
+pkgver=1.1.2
+_rockname=mediator_lua
+_rockrel=0
+pkgrel=1
+pkgdesc="Event handling through channels"
+arch=('i686' 'x86_64')
+url="http://olivinelabs.com/mediator_lua/"
+license=('MIT')
+depends=('lua')
+makedepends=('luarocks')
+conflicts=()
+source=("https://luarocks.org/$_rockname-$pkgver-$_rockrel.rockspec")
+sha256sums=('751debefe0aa00fa93c0ae6371922055289e9948b0231d1430c214118fdb3f3b')
+
+package() {
+ luarocks --tree="$pkgdir/usr" install --deps-mode=none "$_rockname-$pkgver-$_rockrel.rockspec"
+ find "$pkgdir/usr" -name manifest -delete
+}