summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2019-02-10 16:15:55 +0100
committerosch2019-02-10 16:15:55 +0100
commit6fd07973d7792c079ba502b852e019c5d62a5ff8 (patch)
tree02dcfee6f963e334ed8d31d2340a2db4ba4556cf
downloadaur-6fd07973d7792c079ba502b852e019c5d62a5ff8.tar.gz
initial release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..801fd80f5b56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lua-mtmsg
+ pkgdesc = Low-level in-memory message buffers for inter-thread communication for Lua.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/osch/lua-mtmsg#mtmsg
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = luarocks
+ depends = lua
+ source = https://github.com/osch/lua-mtmsg/archive/v0.3.1.tar.gz
+ md5sums = 3c3e935baf7a28362ec7a092fdb8b56f
+
+pkgname = lua-mtmsg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ac3673fef77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: osch <oliver@luced.de>
+
+pkgluaname=mtmsg
+pkgname=lua-$pkgluaname
+pkgver=0.3.1
+pkgrel=1
+rockrel=1
+pkgdesc="Low-level in-memory message buffers for inter-thread communication for Lua."
+arch=("i686" "x86_64")
+url="https://github.com/osch/lua-mtmsg#mtmsg"
+license=("MIT")
+depends=("lua")
+makedepends=("luarocks")
+source=("https://github.com/osch/$pkgname/archive/v$pkgver.tar.gz")
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ luarocks --tree="$pkgdir/usr" make "rockspecs/$pkgluaname-$pkgver-$rockrel.rockspec"
+ mkdir -p "$pkgdir/usr/share/doc"
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ mv "$pkgdir/usr/lib/luarocks/rocks-"*"/$pkgluaname/$pkgver-$rockrel/doc" "$pkgdir/usr/share/doc/$pkgname"
+ chmod -R 0644 "$pkgdir/usr/share/doc/$pkgname"/*
+ ln -s "../../doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm -rf "$pkgdir/usr/lib/luarocks"
+}
+
+md5sums=('3c3e935baf7a28362ec7a092fdb8b56f')