summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEzequiel Juarez Garcia2021-05-18 17:36:57 -0400
committerEzequiel Juarez Garcia2021-05-18 17:36:57 -0400
commit2c1b075dc97b0c263e92a79b33bcf50d44d514bd (patch)
treea0f00e9c2e45a56c460e1ced164e404d9bf36f81
parent55be18bed2d64700b5bc439f63385416c20b5c7c (diff)
downloadaur-2c1b075dc97b0c263e92a79b33bcf50d44d514bd.tar.gz
Require Lua 5.3 to fix compilation issues
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e5ee4e9eb95..ae85c003fe99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = lua-pam-git
pkgdesc = A module for lua to use PAM
pkgver = r12.4820711
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/RMTT/lua-pam
install = lua-pam-git.install
arch = x86_64
license = MIT
makedepends = cmake
depends = pam
- depends = lua
+ depends = lua53
provides = lua-pam
source = git+https://github.com/RMTT/lua-pam.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d7c8f4c098f4..dbbdd1344d93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_gitname=lua-pam
pkgname=lua-pam-git
pkgver=r12.4820711
-pkgrel=1
+pkgrel=2
pkgdesc="A module for lua to use PAM"
arch=(x86_64)
url="https://github.com/RMTT/${_gitname}"
license=('MIT')
-depends=(pam lua)
+depends=(pam lua53)
makedepends=(cmake)
provides=(lua-pam)
install=lua-pam-git.install
@@ -22,12 +22,14 @@ pkgver() {
build() {
cd ${_gitname}
+ sed -i 's/target_link_libraries(lua_pam lua pam)/target_link_libraries(lua_pam lua5.3 pam)/' CMakeLists.txt
+ sed -i 's/lua.hpp/lua5.3\/lua.hpp/' src/main.cpp
cmake . -B build
make -C build
}
package() {
cd ${_gitname}
- install -Dm 755 -t "${pkgdir}/usr/lib/${_gitname}" build/liblua_pam.so
+ install -Dm 755 build/liblua_pam.so -t "${pkgdir}/usr/lib/${_gitname}"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}