summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEzequiel Juarez Garcia2020-07-28 17:30:34 -0400
committerEzequiel Juarez Garcia2020-07-28 17:32:07 -0400
commita8120aa0f676117955b315d9a9a977963a9cf58c (patch)
treeb674c72f9c0041dad3a644287ecb1c74fbc95af7
downloadaur-a8120aa0f676117955b315d9a9a977963a9cf58c.tar.gz
Add initial package version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--lua-pam-git.install12
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a8c1d1c3d20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lua-pam-git
+ pkgdesc = A module for lua to use PAM
+ pkgver = r8.7756d5d
+ pkgrel = 1
+ url = https://github.com/RMTT/lua-pam
+ install = lua-pam-git.install
+ arch = x86_64
+ license = unknown
+ makedepends = cmake
+ depends = pam
+ depends = lua
+ provides = lua-pam
+ source = git+https://github.com/RMTT/lua-pam.git
+ sha256sums = SKIP
+
+pkgname = lua-pam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85eb53eb4d9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: CrunchySnake
+
+_gitname=lua-pam
+pkgname=lua-pam-git
+pkgver=r8.7756d5d
+pkgrel=1
+pkgdesc="A module for lua to use PAM"
+arch=(x86_64)
+url="https://github.com/RMTT/${_gitname}"
+license=(unknown)
+depends=(pam lua)
+makedepends=(cmake)
+provides=(lua-pam)
+install=lua-pam-git.install
+source=("git+${url}.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${_gitname}
+ cmake . -B build
+ make -C build
+}
+
+package() {
+ cd ${_gitname}
+ install -Dm 755 -t "${pkgdir}/usr/lib/${_gitname}" build/liblua_pam.so
+}
diff --git a/lua-pam-git.install b/lua-pam-git.install
new file mode 100644
index 000000000000..995c2310a53a
--- /dev/null
+++ b/lua-pam-git.install
@@ -0,0 +1,12 @@
+msg () {
+ echo "This package installed a file named liblua_pam.so into /usr/lib/lua-pam/."
+ echo "Depending on your needs, you can copy it, add a symbolic link to it, etc."
+}
+
+post_install () {
+ msg
+}
+
+post_upgrade () {
+ msg
+}