summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2016-09-16 16:38:58 -0400
committerEric Berquist2016-09-16 16:38:58 -0400
commit390f7c5ef09a9002d44211eb2bbbc6daa8888a40 (patch)
tree03593aef41d0d21edce230cb25c36a1442ced0f2
parenta69c4edb512c25fd5ea7c9d7781d9ea0e85e26aa (diff)
downloadaur-390f7c5ef09a9002d44211eb2bbbc6daa8888a40.tar.gz
Added gitignore.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD9
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c15179544db..bd6f6d288eda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Fri Sep 16 20:37:10 UTC 2016
pkgbase = lua-posix-git
pkgdesc = POSIX library for Lua
- pkgver = 33.2.1.73.g5536f10
- pkgrel = 1
+ pkgver = 33.4.0.11.g3ab67b5
+ pkgrel = 2
url = https://github.com/luaposix/luaposix
arch = x86_64
arch = i686
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e161b5a791a2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# makepkg files
+pkg/
+src/
+*.xz
+
+# source files
+lua-posix/
+
diff --git a/PKGBUILD b/PKGBUILD
index 88c873c3ef66..a55dd0a84f8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
# Contributor: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Sébastien Luttringer
# Contributor: SpepS <dreamspepser at yahoo dot it>
# Contributor: Laszlo Papp <djszapi at archlinux us>
# Contributor: Donald Ephraim Curtis <dcurtis@gmail.com>
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
-# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
_pkgname=lua-posix
pkgname="${_pkgname}-git"
-pkgver=33.2.1.73.g5536f10
-pkgrel=1
+pkgver=33.4.0.11.g3ab67b5
+pkgrel=2
pkgdesc='POSIX library for Lua'
arch=('x86_64' 'i686')
url='https://github.com/luaposix/luaposix'
@@ -36,13 +36,16 @@ build() {
cd "${_pkgname}"
luaver=$(/usr/bin/lua -v | cut -d " " -f 2 | cut -d "." -f 1,2)
+
./bootstrap
+
./configure \
LUA=/usr/bin/lua \
--prefix=/usr \
--libdir=/usr/lib/lua/${luaver} \
--datadir=/usr/share/lua/${luaver} \
--docdir=/usr/share/doc/lua-posix
+
make
}