summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:37:31 +0200
committerStefan Husmann2015-06-09 00:37:31 +0200
commitccd3fa218e10d313040842216c04119cd3e53e2a (patch)
treee4909851de85ee79057cf92ab8b840f46f109835
downloadaur-ccd3fa218e10d313040842216c04119cd3e53e2a.tar.gz
initial version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD46
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4793512e4512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lua-posix-git
+ pkgdesc = POSIX library for Lua
+ pkgver = 33.0.0.18.ge7dee4d
+ pkgrel = 1
+ url = https://github.com/luaposix/luaposix
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = help2man
+ makedepends = ldoc
+ depends = lua
+ provides = lua-posix
+ conflicts = lua-posix
+ options = !makeflags
+ source = git://github.com/luaposix/luaposix.git
+ md5sums = SKIP
+
+pkgname = lua-posix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abfb58549545
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Sébastien Luttringer
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Contributor: Laszlo Papp <djszapi at archlinux us>
+# Contributor: Donald Ephraim Curtis <dcurtis@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=lua-posix-git
+pkgver=33.0.0.18.ge7dee4d
+pkgrel=1
+pkgdesc='POSIX library for Lua'
+arch=('x86_64' 'i686')
+url='https://github.com/luaposix/luaposix'
+license=('MIT')
+depends=('lua')
+conflicts=('lua-posix')
+provides=('lua-posix')
+makedepends=('git' 'help2man' 'ldoc')
+options=('!makeflags')
+source=("git://github.com/luaposix/luaposix.git")
+md5sums=('SKIP')
+_gitname=luaposix
+
+pkgver() {
+ cd "$_gitname"
+ git describe --always | sed 's+^v++' | sed 's+-+.+g'
+}
+
+build() {
+ cd "$_gitname"
+ ./bootstrap
+ ./configure \
+ LUA=/usr/bin/lua \
+ --prefix=/usr \
+ --libdir=/usr/lib/lua/5.2 \
+ --datadir=/usr/share/lua/5.2 \
+ --docdir=/usr/share/doc/lua-posix
+ make
+}
+
+package() {
+ cd "$_gitname"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}