summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-08-10 00:00:50 +0600
committerMubashshir2020-08-10 00:00:50 +0600
commitb70df0de1cc1f5f0799a331fa054635e1d92cc91 (patch)
treee96184d7a22d106412976cf554d2783f00e68c8b
downloadaur-b70df0de1cc1f5f0799a331fa054635e1d92cc91.tar.gz
pkgrel bump
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9792c18a7a5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lua-resty-core
+ pkgdesc = Lua script engine for nginx lua module
+ pkgver = 0.1.19
+ pkgrel = 2
+ url = https://github.com/openresty/lua-resty-core
+ arch = any
+ license = BSD
+ depends = luajit
+ depends = lua-resty-lrucache
+ depends = nginx
+ source = https://github.com/openresty/lua-resty-core/archive/v0.1.19.tar.gz
+ sha256sums = 040878ed9a485ca7f0f8128e4e979280bcf501af875704c8830bec6a68f128f7
+
+pkgname = lua-resty-core
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12d7e1727a4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ahmad Hasan Mubashshir <ahmubashshir@gmail.com>
+
+pkgname=lua-resty-core
+pkgver=0.1.19
+pkgrel=2
+
+pkgdesc='Lua script engine for nginx lua module'
+arch=('any')
+depends=('luajit' 'lua-resty-lrucache' 'nginx')
+url="https://github.com/openresty/lua-resty-core"
+license=('BSD')
+
+source=(
+ https://github.com/openresty/lua-resty-core/archive/v$pkgver.tar.gz
+)
+
+sha256sums=('040878ed9a485ca7f0f8128e4e979280bcf501af875704c8830bec6a68f128f7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" PREFIX=/usr LUA_VERSION=5.1 install
+}