summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-28 18:28:15 +0300
committerDimitris Kiziridis2020-04-28 18:28:15 +0300
commitd549f953e01464e90f181ed2ef0594f09ade6b76 (patch)
tree80eb0714de0c45b26ca25fffc1bb2c74e7b8ff0a
parent7debff4e36e16d3bc045f1c5df8b9bec825fe0d8 (diff)
downloadaur-d549f953e01464e90f181ed2ef0594f09ade6b76.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ac569c7345f..fc4a428bab63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = lua-sci
depends = lua51-xsys
depends = lua52-xsys
depends = openblas-lapack
- source = https://github.com/stepelu/lua-sci/archive/v1.0.0-beta12.tar.gz
+ source = lua-sci-1.0.0.beta12.tar.gz::https://github.com/stepelu/lua-sci/archive/v1.0.0-beta12.tar.gz
source = sci-1.0.0.beta12-1.rockspec
sha256sums = 50785d4e1c0f18c4e54bce99569845b629b9f18f7585dbee64d8bd11ecc98528
sha256sums = 9ab11513ec2950db9a5369d0b57a08707ad64cc5f478bffcd3a0e63116d9715f
diff --git a/PKGBUILD b/PKGBUILD
index 52f72e5e6723..a0612087cf3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=('lua-sci' 'lua51-sci' 'lua52-sci')
+_rockname=sci
pkgver=1.0.0.beta12
+_pkgver=1.0.0-beta12
pkgrel=1
pkgdesc="Scientific Computing with LuaJIT"
arch=('x86_64')
@@ -13,30 +15,34 @@ depends=('luajit'
'lua52-xsys'
'openblas-lapack')
makedepends=('luarocks')
-source=("https://github.com/stepelu/lua-sci/archive/v${pkgver:0:5}-${pkgver:6}.tar.gz"
- 'sci-1.0.0.beta12-1.rockspec')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/stepelu/lua-sci/archive/v${_pkgver}.tar.gz"
+ "${_rockname}-${pkgver}-1.rockspec")
sha256sums=('50785d4e1c0f18c4e54bce99569845b629b9f18f7585dbee64d8bd11ecc98528'
'9ab11513ec2950db9a5369d0b57a08707ad64cc5f478bffcd3a0e63116d9715f')
prepare() {
- ln -s "${srcdir}/sci-1.0.0.beta12-1.rockspec" "lua-sci-${pkgver}"
+ ln -s "${srcdir}/${pkgname}-${pkgver}-1.rockspec" "${pkgname}-${_pkgver}/"
}
build() {
mkdir -p 5.1 5.2 5.3
# Build for 5.1
- (cd 5.1; luarocks build --pack-binary-rock --lua-version=5.1 --deps-mode=none ../"sci-$pkgver-1.rockspec")
+ (cd 5.1; luarocks build --pack-binary-rock --lua-version=5.1 --deps-mode=none ../"${_rockname}-$pkgver-1.rockspec")
# Build for 5.2
- (cd 5.2; luarocks build --pack-binary-rock --lua-version=5.2 --deps-mode=none ../"sci-$pkgver-1.rockspec")
+ (cd 5.2; luarocks build --pack-binary-rock --lua-version=5.2 --deps-mode=none ../"${_rockname}-$pkgver-1.rockspec")
# Build for 5.3
- (cd 5.3; luarocks build --pack-binary-rock --lua-version=5.3 --deps-mode=none ../"sci-$pkgver-1.rockspec")
+ (cd 5.3; luarocks build --pack-binary-rock --lua-version=5.3 --deps-mode=none ../"${_rockname}-$pkgver-1.rockspec")
+
+ rm "${srcdir}/${pkgname}-${_pkgver}/${pkgname}-${pkgver}-1.rockspec"
}
package_lua-sci() {
pkgdesc='Scientific Computing with LuaJIT for Lua 5.3'
- luarocks install --lua-version=5.3 --tree="$pkgdir/usr/" --deps-mode=none 5.3/*.rock
+ luarocks install --lua-version=5.3 --tree="$pkgdir/usr/" --deps-mode=none 5.3/${_rockname}-${pkgver}-1.all.rock
+
+ install -Dm644 "${srcdir}/lua-${_rockname}-${_pkgver}/LICENSE.TXT" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.3/manifest"
@@ -45,7 +51,9 @@ package_lua-sci() {
package_lua51-sci() {
pkgdesc='Scientific Computing with LuaJIT for Lua 5.1'
- luarocks install --lua-version=5.1 --tree="$pkgdir/usr/" --deps-mode=none 5.1/*.rock
+ luarocks install --lua-version=5.1 --tree="$pkgdir/usr/" --deps-mode=none 5.1/${_rockname}-${pkgver}-1.all.rock
+
+ install -Dm644 "${srcdir}/lua-${_rockname}-${_pkgver}/LICENSE.TXT" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.1/manifest"
@@ -54,7 +62,9 @@ package_lua51-sci() {
package_lua52-sci() {
pkgdesc='Scientific Computing with LuaJIT for Lua 5.2'
- luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none 5.2/*.rock
+ luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none 5.2/${_rockname}-${pkgver}-1.all.rock
+
+ install -Dm644 "${srcdir}/lua-${_rockname}-${_pkgver}/LICENSE.TXT" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.2/manifest"