summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcafehaine2018-10-25 13:10:05 +0200
committercafehaine2018-10-25 13:10:05 +0200
commit74635568513720d813990eb64ffa37cfd9445c87 (patch)
tree51e3b01148c20397b111316f6484ffe04b4b8e25
downloadaur-74635568513720d813990eb64ffa37cfd9445c87.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b47cbb7d6fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lua-std-_debug
+ pkgdesc = Lua Debug Hints Library
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/lua-stdlib/_debug#debug-hints-library
+ arch = any
+ license = MIT
+ depends = lua
+ source = lua-std-_debug-1.0.1.tar.gz::https://github.com/lua-stdlib/_debug/archive/v1.0.1.tar.gz
+ md5sums = ccb440f3d84e2d56aab8c3dd6bcd0b18
+
+pkgname = lua-std-_debug
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cd70638071d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Kilian Guillaume "cafehaine" <kilian dot guillaume at gmail dot com>
+pkgname=lua-std-_debug
+_realname=_debug
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Lua Debug Hints Library"
+arch=('any')
+url="https://github.com/lua-stdlib/_debug#debug-hints-library"
+license=('MIT')
+depends=('lua')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/lua-stdlib/_debug/archive/v$pkgver.tar.gz")
+md5sums=('ccb440f3d84e2d56aab8c3dd6bcd0b18')
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 lib/std/$_realname/*.lua -t "$pkgdir"/usr/lib/lua/5.3/std/$_realname/
+}
+