summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-12 13:27:32 +0300
committerCaleb Maclennan2020-02-12 13:27:32 +0300
commited81eb5d1507955f7e7ce458ad1fea42c1eb74e5 (patch)
treec28d67847cdcca81e66e8b355a5eb56fd7d7ff06
parent74635568513720d813990eb64ffa37cfd9445c87 (diff)
downloadaur-ed81eb5d1507955f7e7ce458ad1fea42c1eb74e5.tar.gz
Adopt, provide Lua 5.2 and 5.1 packages
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 42 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b47cbb7d6fd..da5604538beb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
pkgbase = lua-std-_debug
pkgdesc = Lua Debug Hints Library
pkgver = 1.0.1
- pkgrel = 1
- url = https://github.com/lua-stdlib/_debug#debug-hints-library
+ pkgrel = 2
+ url = https://github.com/lua-stdlib/_debug
arch = any
license = MIT
- depends = lua
+ makedepends = luarocks
source = lua-std-_debug-1.0.1.tar.gz::https://github.com/lua-stdlib/_debug/archive/v1.0.1.tar.gz
- md5sums = ccb440f3d84e2d56aab8c3dd6bcd0b18
+ sha256sums = efc560540f08dcf880ac48c6ab527bd741bbe3d6d66202a3c8be3ff5c9e1e907
pkgname = lua-std-_debug
+ depends = lua
+
+pkgname = lua52-std-_debug
+ depends = lua52
+
+pkgname = lua51-std-_debug
+ depends = lua51
diff --git a/PKGBUILD b/PKGBUILD
index 9cd70638071d..a98d12d9df21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,39 @@
# Maintainer: Kilian Guillaume "cafehaine" <kilian dot guillaume at gmail dot com>
-pkgname=lua-std-_debug
-_realname=_debug
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_rockname=std-_debug
+pkgbase=lua-$_rockname
+pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+_pkgname=_debug
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
+_rockrel=1
pkgdesc="Lua Debug Hints Library"
arch=('any')
-url="https://github.com/lua-stdlib/_debug#debug-hints-library"
+url="https://github.com/lua-stdlib/$_pkgname"
license=('MIT')
-depends=('lua')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/lua-stdlib/_debug/archive/v$pkgver.tar.gz")
-md5sums=('ccb440f3d84e2d56aab8c3dd6bcd0b18')
+makedepends=('luarocks')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/lua-stdlib/$_pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('efc560540f08dcf880ac48c6ab527bd741bbe3d6d66202a3c8be3ff5c9e1e907')
+
+_package_helper() {
+ cd "$_pkgname-$pkgver"
+ luarocks --lua-version=$1 --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "${_rockname/-/.}-$pkgver-$_rockrel.rockspec"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_lua-std-_debug() {
+ depends+=('lua')
+ _package_helper 5.3
+}
+
+package_lua52-std-_debug() {
+ depends+=('lua52')
+ _package_helper 5.2
+}
-package() {
- cd "$srcdir/$_realname-$pkgver"
- install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 lib/std/$_realname/*.lua -t "$pkgdir"/usr/lib/lua/5.3/std/$_realname/
+package_lua51-std-_debug() {
+ depends+=('lua51')
+ _package_helper 5.1
}