summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcafehaine2018-10-25 12:03:33 +0200
committercafehaine2018-10-25 12:03:33 +0200
commite6c98c57fbed0b0eee10b5fdb8c04b50c2c705ce (patch)
tree79df994e9371244673db4bb083cd3ef2adb87a66
downloadaur-e6c98c57fbed0b0eee10b5fdb8c04b50c2c705ce.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..116a01cb5969
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lua-std-normalize
+ pkgdesc = Normalized Lua functions
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://github.com/lua-stdlib/normalize#normalized-lua-functions
+ arch = any
+ license = MIT
+ depends = lua
+ source = lua-std-normalize-2.0.2.tar.gz::https://github.com/lua-stdlib/normalize/archive/v2.0.2.tar.gz
+ md5sums = ef79927f6d272182bf5d4fdc5e89dd8f
+
+pkgname = lua-std-normalize
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f25be9c8f9d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Kilian Guillaume "cafehaine" <kilian dot guillaume at gmail dot com>
+pkgname=lua-std-normalize
+_realname=normalize
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="Normalized Lua functions"
+arch=('any')
+url="https://github.com/lua-stdlib/normalize#normalized-lua-functions"
+license=('MIT')
+depends=('lua')
+conflicts=()
+source=("$pkgname-$pkgver.tar.gz::https://github.com/lua-stdlib/normalize/archive/v$pkgver.tar.gz")
+md5sums=('ef79927f6d272182bf5d4fdc5e89dd8f')
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 lib/std/normalize/*.lua -t "$pkgdir"/usr/lib/lua5.3/std/normalize/
+}
+