summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista2015-06-08 12:29:50 +0200
committerFrancesco Colista2015-06-08 12:29:50 +0200
commit899dc9489bb7e6820133bf5db821a031c2901b3c (patch)
tree62adac1df50d425289e06fa82c47b630c475dc4c
downloadaur-899dc9489bb7e6820133bf5db821a031c2901b3c.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb2490aaf3ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lua-stringy
+ pkgdesc = Lua string utility library
+ pkgver = 0.4.0
+ pkgrel = 0
+ url = https://github.com/brentp/lua-projects/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = lua
+ source = https://github.com/brentp/lua-stringy/archive/v0.4.0.zip
+ md5sums = c1e8e8f024ed362af711d615284fd499
+
+pkgname = lua-stringy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7810503d2adb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Cameron Banta <cbanta@gmail.com>
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+pkgname=lua-stringy
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Lua string utility library"
+license=('MIT')
+arch=("i686" "x86_64")
+url="https://github.com/brentp/lua-projects/"
+depends=('lua')
+source=(https://github.com/brentp/${pkgname}/archive/v${pkgver}.zip)
+
+build() {
+ local i
+ cd $pkgname-$pkgver/stringy
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ ${CC:-gcc} ${CFLAGS} -fPIC -shared ${LDFLAGS} -llua -o stringy.so stringy.c || return 1
+ lua stringy_test.lua
+}
+
+package() {
+ local _lualibdir=/usr/lib/lua/5.2
+ cd $pkgname-$pkgver/stringy
+ mkdir -p "$pkgdir"/$_lualibdir
+ cp stringy.so "$pkgdir"/$_lualibdir/
+}
+md5sums=('c1e8e8f024ed362af711d615284fd499')