summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-08 18:51:27 +0300
committerCaleb Maclennan2020-08-08 18:51:27 +0300
commit36772e1baff7a245b55647d5ab6b378c90dab7ba (patch)
tree2e94a0ea79d08ed5298219db9e5150165ad5becd
parent0fdbda3bd1b927408c1fca4c119c72f7a7f7d6d2 (diff)
downloadaur-lua-utf8.tar.gz
upgpkg: lua-utf8 0.1.3-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cef292fb1214..48ad88a2002c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lua-utf8
pkgdesc = Add UTF-8 support to Lua, compatible with Lua string module
- pkgver = 0.1.2
- pkgrel = 3
+ pkgver = 0.1.3
+ pkgrel = 1
url = https://github.com/starwing/luautf8
arch = x86_64
license = MIT
@@ -10,8 +10,8 @@ pkgbase = lua-utf8
makedepends = lua52
makedepends = lua51
makedepends = luarocks
- source = luautf8-0.1.2.tar.gz::https://github.com/starwing/luautf8/archive/0.1.2.tar.gz
- sha256sums = 52578858e4519da7e09d019baef9135fef3ff2dfb0bc0a01e58fba7a70f7be26
+ source = luautf8-0.1.3.tar.gz::https://github.com/starwing/luautf8/archive/0.1.3.tar.gz
+ sha256sums = 208b3423a03a6c2822a2fa6b7cc8092ed7d3c0d792ec12c7cd28d6afaa442e0b
pkgname = lua-utf8
depends = lua
diff --git a/PKGBUILD b/PKGBUILD
index e469289adc70..85d2fc74d8c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
_rockname=luautf8
_pkgname=utf8
pkgname=("lua-$_pkgname" "lua53-$_pkgname" "lua52-$_pkgname" "lua51-$_pkgname")
-pkgver=0.1.2
-_rockrel=0
-pkgrel=3
+pkgver=0.1.3
+_rockrel=1
+pkgrel=1
pkgdesc='Add UTF-8 support to Lua, compatible with Lua string module'
arch=('x86_64')
url="https://github.com/starwing/$_rockname"
license=('MIT')
makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("$_rockname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('52578858e4519da7e09d019baef9135fef3ff2dfb0bc0a01e58fba7a70f7be26')
+sha256sums=('208b3423a03a6c2822a2fa6b7cc8092ed7d3c0d792ec12c7cd28d6afaa442e0b')
_package_helper() {
cd "$_rockname-$pkgver"
luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
- make --deps-mode=none --no-manifest "rockspecs/$_rockname-scm-$_rockrel.rockspec"
+ make --deps-mode=none --no-manifest "rockspecs/$_rockname-$pkgver-$_rockrel.rockspec"
}
package_lua-utf8() {