summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-08-06 11:21:31 +0300
committerCaleb Maclennan2020-08-06 11:21:31 +0300
commit0fdbda3bd1b927408c1fca4c119c72f7a7f7d6d2 (patch)
tree6f7770e315fce0de69a499287569e29699e3e059
parent9317a30671fe7805f58dfa45aa9ea0c6004d10ea (diff)
downloadaur-0fdbda3bd1b927408c1fca4c119c72f7a7f7d6d2.tar.gz
upgpkg: lua-utf8 0.1.2-3
Bump default to Lua 5.4 and add Lua 5.3 split package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0316180494e0..cef292fb1214 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = lua-utf8
pkgdesc = Add UTF-8 support to Lua, compatible with Lua string module
pkgver = 0.1.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/starwing/luautf8
arch = x86_64
license = MIT
- makedepends = luarocks
makedepends = lua
+ makedepends = lua53
makedepends = lua52
makedepends = lua51
+ makedepends = luarocks
source = luautf8-0.1.2.tar.gz::https://github.com/starwing/luautf8/archive/0.1.2.tar.gz
sha256sums = 52578858e4519da7e09d019baef9135fef3ff2dfb0bc0a01e58fba7a70f7be26
pkgname = lua-utf8
depends = lua
+pkgname = lua53-utf8
+ depends = lua53
+
pkgname = lua52-utf8
depends = lua52
diff --git a/PKGBUILD b/PKGBUILD
index 6e2802000add..e469289adc70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
_rockname=luautf8
-pkgname=('lua-utf8' 'lua52-utf8' 'lua51-utf8')
+_pkgname=utf8
+pkgname=("lua-$_pkgname" "lua53-$_pkgname" "lua52-$_pkgname" "lua51-$_pkgname")
pkgver=0.1.2
_rockrel=0
-pkgrel=2
+pkgrel=3
pkgdesc='Add UTF-8 support to Lua, compatible with Lua string module'
arch=('x86_64')
url="https://github.com/starwing/$_rockname"
license=('MIT')
-makedepends=('luarocks' 'lua' 'lua52' 'lua51')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("$_rockname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('52578858e4519da7e09d019baef9135fef3ff2dfb0bc0a01e58fba7a70f7be26')
_package_helper() {
cd "$_rockname-$pkgver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "rockspecs/$_rockname-scm-$_rockrel.rockspec"
+ luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "rockspecs/$_rockname-scm-$_rockrel.rockspec"
}
package_lua-utf8() {
depends=('lua')
+ _package_helper 5.4
+}
+
+package_lua53-utf8() {
+ depends=('lua53')
_package_helper 5.3
}