summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2018-08-03 10:19:19 +0300
committerCaleb Maclennan2018-08-03 10:19:37 +0300
commit87b4d673b0b26cd56366d4d1b539ee580bd94d5a (patch)
tree02b7109a02005d73232b0cf9c9eb3651b596ef75
parent0ce2e335be24aa563674c47116320194d1ab9d63 (diff)
downloadaur-87b4d673b0b26cd56366d4d1b539ee580bd94d5a.tar.gz
Update upstream homepage to https address and cleanup packaging
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1f4bbe103ff..4100d7d40324 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Mar 1 11:51:54 UTC 2018
+# Fri Aug 3 07:19:11 UTC 2018
pkgbase = lua-utf8
pkgdesc = Add UTF-8 support to Lua, compatible with Lua string module.
pkgver = 0.1.1
pkgrel = 3
- url = http://github.com/starwing/luautf8
- arch = i686
+ url = https://github.com/starwing/luautf8
arch = x86_64
license = MIT
makedepends = luarocks
diff --git a/PKGBUILD b/PKGBUILD
index 14740a05e8e2..2b2c2ab44b46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,17 @@ _rockname=luautf8
_rockrel=1
pkgrel=3
pkgdesc='Add UTF-8 support to Lua, compatible with Lua string module.'
-arch=('i686' 'x86_64')
-url='http://github.com/starwing/luautf8'
+arch=('x86_64')
+url='https://github.com/starwing/luautf8'
license=('MIT')
depends=('lua')
makedepends=('luarocks')
-conflicts=()
source=("https://luarocks.org/${_rockname}-${pkgver}-${_rockrel}.src.rock")
noextract=("${_rockname}-${pkgver}-${_rockrel}.src.rock")
sha256sums=('51aa211a9d39d62c65bfcca4eccb8482a11bfe918992eed58104b646338d62a0')
package() {
- luarocks --tree="$pkgdir/usr" install --deps-mode=none "${_rockname}-${pkgver}-${_rockrel}.src.rock"
- find "$pkgdir/usr" -name manifest -delete
+ luarocks --tree="$pkgdir/usr" install --deps-mode=none "${_rockname}-${pkgver}-${_rockrel}.src.rock"
+ find "$pkgdir/usr" -name manifest -delete
}